Mail/news silliness has infected the Scripts & Windows panel

RESOLVED INVALID

Status

SeaMonkey
Preferences
RESOLVED INVALID
16 years ago
6 years ago

People

(Reporter: Matthew Paul Thomas, Unassigned)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [2012 Fall Equinox])

Attachments

(5 attachments)

(Reporter)

Description

16 years ago
Build: 2002061708, Mac OS 9.2

To reproduce:
1.  Open the Preferences dialog.
2.  Open the `Scripts & Windows' panel.
3.  Look at the contents.

What you see:
2.  The panel is called `Scripts and Plugins', which (a) is a spelling mistake,
    (b) makes it harder to find the prefs to control the opening/moving/resizing 
    of windows, and (c) makes it harder to find the prefs which really *are*
    about plug-ins.
3.  *   There is a checkbox for mail/news plug-ins, which has nothing to do
        with either scripts or windows.
    *   There is a groupbox surrounding the checkbox, which is useless since
        there's only one checkbox.

What you should see:
*   The panel as it looked before this checkbox was added.
*   The mail/news plug-ins checkbox should be either with the rest of the
    plug-ins prefs (the Helper Apps category) or with the rest of the mail/news
    prefs (the Mail & Newsgroups branch), not in this completely unrelated
    panel.

Comment 1

16 years ago
1.9 Jun 3 21:14 bug 147877
could it take Enable JS in Mail and News with it if it moves into its own 
panel? pretty please?
Assignee: ben → ducarroz
Keywords: regression

Comment 2

16 years ago
It can't go in the "Helper Apps" category because its a sub item under 
"Navigator" and this is a Mail & Newsgroups related pref. I agree it belongs in 
the Mail & Newsgroups hierarchy. 

In Mail/News, enabling plug-ins is a security related issue, so there should 
probably be a dedicated panel in Mail/News prefs for security related 
features. Currently, the Mail/News security prefs are scattered about. Some 
of them seem to be intertwined with the Nav prefs though, so it might take 
some work to pull them out onto their own panel.

1. Advanced: Scripts & Plugins: Enable plug-ins for Mail & Newsgroups
2. Advanced: Scripts & Plugins: Enable JavaScript for Mail & Newsgroups. If this 
moved to Mail/News Security panel, do all the checkboxes need to be duplicated, 
and hence work independently?
3.Priv and Sec: Cookies: Disable cookies in Mail & Newsgroups. Again, these seem 
to be intertwined with the Nav cookie prefs.
4. Priv and Sec: Images: Do not load remote images in Mail & Newsgroup msgs. 
Again, these seem to be intertwined with the Nav cookie prefs.

Should Mail and Newsgroup plug-ins just be moved, or all the Mail/News related 
security items as well, onto their own pref panel?
(Reporter)

Comment 3

16 years ago
Ideally, all the mail/news items should be in their own *dialog* -- Navigator
and mail/news should have separate prefs dialogs for the same reason that (for
example) Photoshop and Illustrator have separate prefs dialogs.

In the meantime, I suggest:
(1) rejig the `Message Display' panel to make room for the JavaScript and
    plug-in prefs at the bottom
    (a) get rid of the group boxes
    (b) `Display plain text using: ( ) Proportional font  (*) Monospace font'
    (c) delete the redundant `When viewing plain text messages:'
    (d) `[/] Wrap plain text to fit window width'
    (e) remove the emoticon example (it's highly distracting, anyway)
    (f) `Display emoticons (smileys) as graphics'
(2) restore the `Scripts & Windows' panel to its former state (but without the
    mail/news JS checkbox)
(3) move the `Scripts & Windows' panel from the `Advanced' branch to the end of
    the `Navigator' branch.
reassign to varada...
Assignee: ducarroz → varada

Updated

16 years ago
Keywords: mozilla1.1

Comment 5

16 years ago
Is there a seperate bug for this issue on Windows or should this be All/All?

Updated

16 years ago
OS: Mac System 9.x → All
Hardware: Macintosh → All

Comment 6

16 years ago
jglick: About the need for a mailnews security panel: I don't see any reason why
any user would ever possibly want to allow mailnews to use plug-ins, JavaScript,
cookies or load remote images. Any reason why we can't just disallow these
actions and remove the prefs?

Comment 7

16 years ago
Because maybe some day even non-geeks may want to use mozilla. Of course it
doesn't look that way now.

Comment 8

16 years ago
Markus: What's your point? Why would a non-geek care about enabling or disabling
cookies in email?

Comment 9

16 years ago
There are some people out there, who are more than happy to use HTML-Mail. Most
Geeks/Nerds I know don't use HTML-Mail. But some might try Mozilla, and wonder
why his/her cool ZDNet/PCWorld/Whatever-newsletter doesn't work any more. And
they won't say: "Hey cool, Mozilla protects my privacy and don't display these
fancy images. Now that's great!"
That covers remote images. Now - javascript. I get mail from a hardware
distributor in Germany. These mails contain advertising for some of their
new/special articles, and a <FORM>, with which you can order these articles from
within your mailclient. Now guess what they use to verify if any of the usual
textboxes (name/address/etc) is empty ?
Plugins: Ah well - Flash is everywhere, isn't it ? OTOH I never heard about
flash(-ads) in mails.
Cookies: Ok - there I have no clue why this is possible at all.

My point is: There is legitimate use of remote Images and even JS in mails, and
it's up to the user to decide.

Comment 10

16 years ago
"it's up to the user to decide"? Non-geeks don't know what JavaScript is; they
might switch the pref off and on a couple of times to see if there is any
obvious difference, and then leave it at a random setting. If a non-geek user
sees that his fancy HTML+JavaScript+Flash newsletter doesn't work, having a
checkbox saying "Enable JavaScript in mailnews" won't help since he simply
doesn't know what the checkbox means.

Comment 11

16 years ago
Or won't even bother to search for one. But he wouldn't need to. Since it would
work out-of-the-box.

Comment 12

16 years ago
For the fancy newsletter to work out-of-the-box, JavaScript in mailnews would
have to be enabled by default; currently it's disabled. Are you proposing that
it be enabled?

Comment 13

16 years ago
NS7.0pr1 has it enabled by default. And I'm proposing that it should be possible
to enable.

(Although I disable remote images, javascript, plugins etc as soon as possible,
I'm not sure if it's the right thing for mozilla/netscape to do so. Mozilla with
disabled JS in mail, and Netscape with enabled JS in mail seems like a good
approach to me.)

Comment 14

16 years ago
Taking.
Assignee: varada → jonasj

Updated

16 years ago
Target Milestone: --- → mozilla1.2alpha

Comment 15

16 years ago
Created attachment 93843 [details] [diff] [review]
proposed patch

Comment 16

16 years ago
Created attachment 93845 [details]
scripts & windows -- before

Comment 17

16 years ago
Created attachment 93846 [details]
scripts & windows -- after

Comment 18

16 years ago
Created attachment 93847 [details]
message display -- before

Comment 19

16 years ago
Created attachment 93848 [details]
message display -- after

Comment 20

16 years ago
mpt, any comments before I go looking for r/sr?

Comment 21

16 years ago
If the "Enable JS for Mail & Newsgroups" checkbox on the Message Dislay dialog 
is checked, do the 8 checkboxes under "Allow scripts to:" on the Navigator 
Scripts and Windows dialog apply to mail and news as well? If so, that 
relationship isn't very obvious. Things that are directly related like that, 
should be grouped together.

Comment 22

16 years ago
I can't begin to imagine why anyone would ever want to allow mail messages (or
especially newsgroup articles) to open popups, or resize windows, or most of the
other things that the checkboxes control for webpages.  If those things were to
be enabled for mailnews, let it be in a hidden pref and not by further gunking
the scripts & windows panel.

Comment 23

16 years ago
bug 80415 [mozilla1.2alpha, varada@netscape.com] - Message Display, Composition
and Send Format pref panels don't fit.  

No you may not abuse the message display panel for this stuff until the message
display panel actually fits, at which point you probably won't be able to add
the content you want because doing so will make it not fit again.

please make a new panel.

Comment 24

16 years ago
> If the "Enable JS for Mail & Newsgroups" checkbox on the Message Dislay dialog 
> is checked, do the 8 checkboxes under "Allow scripts to:" on the Navigator 
> Scripts and Windows dialog apply to mail and news as well?

Yes.

> If so, that relationship isn't very obvious. Things that are directly related
> like that, should be grouped together.

mpt?

Comment 25

16 years ago
timeless:

> No you may not abuse the message display panel for this stuff until the message
> display panel actually fits

Uh, this patch *makes* the content fit.

Comment 26

16 years ago
--> default assignee
Assignee: jonasj.bugzilla → ben
Product: Browser → Seamonkey
Assignee: bugs → prefs
QA Contact: bugzilla
(Filter "spam" on 'prefs-nobody-20080612'.)
Assignee: prefs → nobody
QA Contact: prefs
Target Milestone: mozilla1.2alpha → ---

Comment 28

6 years ago
This UI changes a lot from report time making this bug obsolete, so closing it
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
Whiteboard: [2012 Fall Equinox]
You need to log in before you can comment on or make changes to this bug.