Closed Bug 1531444 Opened 2 years ago Closed 2 years ago

Confirm that CDN caching is enabled and requested URLs are consistent

Categories

(Firefox :: New Tab Page, defect, P2)

defect

Tracking

()

RESOLVED FIXED
Iteration:
68.1 - Mar 18 - 31

People

(Reporter: gsuntop, Assigned: mathijs)

References

Details

Telemetry is showing unusually high feed request time.

Please ensure that the CDN caching is enabled and also investigate URL requests to ensure that a cachebusting scenario isn't in effect (EG: random or highly variable query values being appended).

We're actually using Akamai instead of CloudFront as the CDN. Digi took a look and it seems that Akamai doesn't offer fine-grained analytics to check the cache hits/misses for a particular endpoint.

It's unlikely that this is the cause, because I see a distinct difference between making requests to getpocket.com (~400 ms) and getpocket.cdn.mozilla.net (~20 ms). Additionally the feeds use the same endpoint as on release, so we should get the same performance there.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Blocks: 1534462
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.