Status

enhancement
RESOLVED INVALID
4 months ago
3 months ago

People

(Reporter: ato, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

4 months ago

geckodriver, which is part of the standard Firefox build, depends
on uses the bzip2-sys Rust crate which has libbz2-dev as a build
dependency. We need to add this to ./mach bootstrap.

We are already building bz2 ourselves, we should try to use that instead.

Reporter

Comment 2

4 months ago

I am mistaken, but for another reason. The cause of the build
failing was that ./mach build testing/geckodriver is not hooked
up as a dependency to ./mach configure. This causes some
mozilla-config.h problem that again causes bzip2-sys to not compile
successfully. I examined bzip2-sys, and it ships/vendors libbz2-dev,
so the problem here was not that libbz2-dev was missing.

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → INVALID
Reporter

Updated

3 months ago
See Also: → 1532232
You need to log in before you can comment on or make changes to this bug.