Crash in View | Character Coding

VERIFIED INVALID

Status

()

Core
Internationalization
--
blocker
VERIFIED INVALID
16 years ago
16 years ago

People

(Reporter: tracy, Assigned: nhottanscp)

Tracking

(4 keywords)

Trunk
PowerPC
Mac System 9.x
crash, intl, regression, smoketest
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
seen on mac os9 commercial build 2002-06-20-03-trunk

-launch the browser
-click View  (menu drops down)
-mouse over Character Coding

CRASH!

This is blocking encoding a mail message with a foriegn font.

talkback report:

Incident ID 7540633
Stack Signature .__ptr_glue b4e9dc5f
Email Address twalker@netscape.com
Product ID MozillaTrunk
Build ID 2002062003
Trigger Time 2002-06-20 08:57:37
Platform MacOS
Operating System MacOS version 9.2.1
Module AppComponents
URL visited
User Comments crash in View | Character coding
Trigger Reason PowerPC unmapped memory exception
Source File Name
Trigger Line No.
Stack Trace
.__ptr_glue
nsCharsetMenuObserver::Observe() [nsCharsetMenu.cpp, line 380]
nsObserverService::NotifyObservers() [nsObserverService.cpp, line 211]
CODE.10
XPTC_InvokeByIndex() [xptcinvoke_mac.cpp, line 145]
XPCWrappedNative::CallMethod() [xpcwrappednative.cpp, line 1993]
XPC_WN_CallMethod() [xpcwrappednativejsops.cpp, line 1266]
js_Invoke() [jsinterp.c, line 788]
js_Interpret() [jsinterp.c, line 2743]
(Reporter)

Updated

16 years ago
Keywords: regression, smoketest
(Assignee)

Comment 1

16 years ago
No crach on MacOS X?
(Reporter)

Comment 2

16 years ago
OSX does not crash in View | Character Coding

Comment 3

16 years ago
alecf?
Assignee: blaker → yokoyama
Component: XP Apps: GUI Features → Internationalization
Keywords: crash
QA Contact: paw → ruixu

Comment 4

16 years ago
Mac issue -> nhotta
cc ftang
Assignee: yokoyama → nhotta
(Assignee)

Comment 5

16 years ago
Here is a list of check ins. We can ignore today's check in because the bug was
reported for 2002-06-20-03-trunk.

http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=day&mindate=&maxdate=&cvsroot=%2Fcvsroot

I am pulling Classic build now, it will take few hours to build it.

Comment 6

16 years ago
The steps listed do not cause a crash in my debug build. Possible packaging issue?
(Assignee)

Comment 7

16 years ago
http://ftp.mozilla.org/pub/mozilla/nightly/2002-06-20-03-trunk/

Yes, it may be a packaging issue. The mozilla trunk build does not have the crash.
I am not familiar with packaging. What could cause this kind of problem?
(Reporter)

Comment 8

16 years ago
cc'ing jj...perhaps he can help.

Comment 9

16 years ago
adding Dan to cc list.
(Assignee)

Comment 10

16 years ago
Using the commercial build, it also crashes with the pref dialog selecting
either browser language, message view, message compose. All of them have popup
menu for charsets.

Updated

16 years ago
Keywords: intl
QA Contact: ruixu → ylong

Comment 11

16 years ago
crashes using this morning's depend build 
ftp://sweetlou.mcom.com/products/client/6.x/macos/8.x/ppc/2002-06-20-08-trunk/
which is run subsequent to the early morning clobber build which the problem was
initally reported on. 
(Assignee)

Comment 12

16 years ago
I got the crash with yesterday's trunk 2002061908.
talkback ID 7547066

I will check earlier build.

Comment 13

16 years ago
So, is this a commercial only bug then?
(Assignee)

Comment 14

16 years ago
Yes, looks like so.
(Assignee)

Comment 15

16 years ago
06/14 commercial does not have the crash. Then from 06/15 to 06/18 the app does
not launch. And 06/19 build has the crash.

Comment 16

16 years ago
<sigh> Building commercial debug now...
(Assignee)

Comment 17

16 years ago
I think the trunk can be opened because this only happens with commercial.

Tracy, could you open a bugscape bug and close this bug?
(Reporter)

Comment 18

16 years ago
closing as invalid for mozilla
opened bugscape bug 16927
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 19

16 years ago
Mark as verified cause we have a bugscape bug for this.
Status: RESOLVED → VERIFIED

Comment 20

16 years ago
This does happen with Mozilla on Linux if component.reg is missing - please see
bug 152545.
You need to log in before you can comment on or make changes to this bug.