Firefox is parsing and using source-level msid

RESOLVED FIXED in Firefox 67

Status

()

defect
P3
normal
Rank:
25
RESOLVED FIXED
3 months ago
2 months ago

People

(Reporter: bwc, Assigned: bwc)

Tracking

unspecified
mozilla67
Points:
---

Firefox Tracking Flags

(firefox67 fixed)

Details

Attachments

(2 attachments)

https://jsfiddle.net/xbwmks2o/1/

I'm guessing this is a bug down in sipcc. I wonder what other source-level attributes it is letting through.

Rank: 15
Priority: -- → P2

Nope, this is an old interop hack for Chrome. I wonder if we need this still? If we do, we shouldn't be looking at source-level msid if there are media-level msid.

Rank: 15 → 25
Priority: P2 → P3
Duplicate of this bug: 1525573
Assignee: nobody → docfaraday

Comment 7

2 months ago
Pushed by bcampen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/466d9c2c222d
Part 0: Update the expected behavior of a test-case, and add further testing. r=jib
https://hg.mozilla.org/integration/autoland/rev/129506229526
Part 1: Ignore source-level msid if media-level msid is present. r=mjf

Comment 8

2 months ago
bugherder
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/16011 for changes under testing/web-platform/tests
You need to log in before you can comment on or make changes to this bug.