Closed Bug 1531531 Opened 9 months ago Closed 8 months ago

Update GeckoView API implementation to use scrollToVisual() in place of window.scrollTo()

Categories

(GeckoView :: General, defect, P1)

Unspecified
Android
defect

Tracking

(firefox65 wontfix, firefox66 wontfix, firefox67 wontfix, firefox68 fixed)

RESOLVED FIXED
mozilla68
Tracking Status
firefox65 --- wontfix
firefox66 --- wontfix
firefox67 --- wontfix
firefox68 --- fixed

People

(Reporter: rbarker, Assigned: rbarker)

References

()

Details

(Whiteboard: [gvtv:p2] [geckoview:p2])

Attachments

(1 file)

Bug https://bugzilla.mozilla.org/show_bug.cgi?id=1516056 changes the way window.scrollBy() and window.scrollTo() behave. The GeckoView API for scrolling needs to be updated to use scrollToVisual() in order to work as designed.

Assignee: nobody → rbarker
Depends on: 1531535

David says GV wants this feature for Fire TV scrolling. Is this an internal GV issue? Or will the FFTV front-end team need to change how they use the GV API?

OS: All → Android
Whiteboard: [gvtv]

My understanding is that it's internal, i.e. the thing we're adjusting is the implementation of the GeckoView API.

Summary: Update GeckoView API to use scrollToVisual() in place of window.scrollTo() → Update GeckoView API implementation to use scrollToVisual() in place of window.scrollTo()

I looked a the FFTV source and I don't think it is being used yet. However, the API should not change, just the underlying implementation.

Randall says this bug is a problem on Fire TV when scrolling with the D-Pad. The page up/down distance doesn't match the viewport height.

needinfo'ing David because he said he would follow up with Jessie and Maire about getting Gfx team help.

Flags: needinfo?(dbolter)
Priority: -- → P1

(In reply to Chris Peterson [:cpeterson] from comment #4)

needinfo'ing David because he said he would follow up with Jessie and Maire about getting Gfx team help.

I already have an email into Botond :) (re: bug 1531535 comment 1, I'll drop a NI for Botond over there)

Flags: needinfo?(dbolter)
Whiteboard: [gvtv] → [gvtv:p2] [geckoview:p2]
Blocks: 1516056
Depends on: 1536157

Adding the URL of a test page for this.

Depends on: 1539687
Pushed by rbarker@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/75d1ab7e1346
Update GeckoView API implementation to use scrollToVisual() in place of window.scrollTo() r=geckoview-reviewers,botond,esawin,droeh
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
You need to log in before you can comment on or make changes to this bug.