autocomplete: list of matching results doesn't match text typed into location bar

RESOLVED INVALID

Status

SeaMonkey
UI Design
--
minor
RESOLVED INVALID
16 years ago
10 years ago

People

(Reporter: Felipe Nievinski, Assigned: Samir Gehani)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1a) Gecko/20020611
BuildID:    2002061104

Navigator can automatically complete text typed into location bar, optionally
showing a list of matching results.
Sometimes this list doesnt match the text typed into location bar.

Reproducible: Always
Steps to Reproduce:
1. Set the Navigator preferences to (1) automatically complete text typed into
Location bar and (2) show list of matching results.
2. Type anything into location bar. The list of matching results (if any) will
drop below the location bar.
3. Press the Home key. Now you're at the start of location string. Type anything
else. The text typed into location bar has changed, but the list of matching
results remains the same (possibly wrong).
4. press the End key. Now you're at the end of the location string. Anything you
type will make navigator to wake-up and refresh the list of matching results.

Actual Results:  - already described together with the steps to reproduce.

Expected Results:  the list of matching results reflecting the current text
typed into location bar.

Tested with both skins (classic and modern).

Modifications of the described behaviour can affect the "autocomplete best match
as you type" feature.

Comment 1

16 years ago
Confirming this with a current build on Win2k.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: autocomplete: list of matching results doesnt match text typed into location bar → autocomplete: list of matching results doesnt match text typed into location bar

Updated

16 years ago
Summary: autocomplete: list of matching results doesnt match text typed into location bar → autocomplete: list of matching results doesn't match text typed into location bar

Comment 2

15 years ago
*** Bug 206720 has been marked as a duplicate of this bug. ***
Product: Core → Mozilla Application Suite

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.