windows/aarch64 - devtools/client/inspector/markup/test/browser_markup_anonymous_02.js, browser_markup_anonymous_03.js, browser_markup_anonymous_04.js | A promise chain failed to handle a rejection | type hasAccessibilityProperties failed

RESOLVED FIXED in Firefox 67

Status

defect
P5
normal
RESOLVED FIXED
3 months ago
2 months ago

People

(Reporter: intermittent-bug-filer, Assigned: egao)

Tracking

(Blocks 1 bug)

unspecified
Firefox 67
Dependency tree / graph

Firefox Tracking Flags

(firefox67 fixed)

Details

Attachments

(2 attachments)

Reporter

Description

3 months ago
treeherder

#[markdown(off)]
Filed by: egao [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=230906088&repo=try

https://queue.taskcluster.net/v1/task/YYDPhUBRQ4yoZ-WALR6Q1A/runs/0/artifacts/public/logs/live_backing.log

Observed during windows10-aarch64/opt-mochitest-devtools-e10s-7.

Multiple failures for files:
- browser_markup_anonymous_02.js
- browser_markup_anonymous_03.js
- browser_markup_anonymous_04.js

Context:
00:51:08 INFO - TEST-START | devtools/client/inspector/markup/test/browser_markup_anonymous_02.js
00:51:08 INFO - Entering test bound
00:51:08 INFO - Adding a new tab with URL: http://example.com/browser/devtools/client/inspector/markup/test/doc_markup_anonymous_xul.xul
00:51:08 INFO - Tab added and finished loading
00:51:08 INFO - Opening the inspector
00:51:08 INFO - Opening the toolbox
00:51:09 INFO - GECKO(3608) | console.log: "[DISPATCH] action type:" "UPDATE_GRIDS"
00:51:09 INFO - GECKO(3608) | console.log: "[DISPATCH] action type:" "CLEAR_FLEXBOX"
00:51:09 INFO - GECKO(3608) | console.log: "[DISPATCH] action type:" "UPDATE_OFFSET_PARENT"
00:51:09 INFO - GECKO(3608) | console.log: "[DISPATCH] action type:" "UPDATE_LAYOUT"
00:51:09 INFO - Toolbox opened and focused
00:51:09 INFO - TEST-PASS | devtools/client/inspector/markup/test/browser_markup_anonymous_02.js | Correct number of children -
00:51:09 INFO - TEST-PASS | devtools/client/inspector/markup/test/browser_markup_anonymous_02.js | Children returned from walker -
00:51:09 INFO - TEST-PASS | devtools/client/inspector/markup/test/browser_markup_anonymous_02.js | Toolbarbutton is not anonymous -
00:51:09 INFO - Selecting the node for '[Front for domnode/server1.conn6.child1/domnode31]'
00:51:09 INFO - GECKO(3608) | console.log: "[DISPATCH] action type:" "CLEAR_FLEXBOX"
00:51:09 INFO - TEST-PASS | devtools/client/inspector/markup/test/browser_markup_anonymous_02.js | Delete menu item is enabled -
00:51:09 INFO - TEST-PASS | devtools/client/inspector/markup/test/browser_markup_anonymous_02.js | Edit HTML menu item is enabled -
00:51:09 INFO - TEST-PASS | devtools/client/inspector/markup/test/browser_markup_anonymous_02.js | Paste HTML menu item is enabled -
00:51:09 INFO - TEST-PASS | devtools/client/inspector/markup/test/browser_markup_anonymous_02.js | Child is anonymous -
00:51:09 INFO - TEST-PASS | devtools/client/inspector/markup/test/browser_markup_anonymous_02.js | Child is XBL anonymous -
00:51:09 INFO - TEST-PASS | devtools/client/inspector/markup/test/browser_markup_anonymous_02.js | Child is not shadow anonymous -
00:51:09 INFO - TEST-PASS | devtools/client/inspector/markup/test/browser_markup_anonymous_02.js | Child is not native anonymous -
00:51:09 INFO - Selecting the node for '[Front for domnode/server1.conn6.child1/domnode36]'
00:51:09 INFO - GECKO(3608) | console.log: "[DISPATCH] action type:" "CLEAR_FLEXBOX"
00:51:09 INFO - TEST-PASS | devtools/client/inspector/markup/test/browser_markup_anonymous_02.js | Delete menu item is disabled -
00:51:09 INFO - TEST-PASS | devtools/client/inspector/markup/test/browser_markup_anonymous_02.js | Edit HTML menu item is disabled -
00:51:09 INFO - TEST-PASS | devtools/client/inspector/markup/test/browser_markup_anonymous_02.js | Paste HTML menu item is disabled -
00:51:09 INFO - TEST-PASS | devtools/client/inspector/markup/test/browser_markup_anonymous_02.js | Child is anonymous -
00:51:09 INFO - TEST-PASS | devtools/client/inspector/markup/test/browser_markup_anonymous_02.js | Child is XBL anonymous -
00:51:09 INFO - TEST-PASS | devtools/client/inspector/markup/test/browser_markup_anonymous_02.js | Child is not shadow anonymous -
00:51:09 INFO - TEST-PASS | devtools/client/inspector/markup/test/browser_markup_anonymous_02.js | Child is not native anonymous -
00:51:09 INFO - Selecting the node for '[Front for domnode/server1.conn6.child1/domnode37]'
00:51:09 INFO - GECKO(3608) | console.log: "[DISPATCH] action type:" "CLEAR_FLEXBOX"
00:51:09 INFO - TEST-PASS | devtools/client/inspector/markup/test/browser_markup_anonymous_02.js | Delete menu item is disabled -
00:51:09 INFO - TEST-PASS | devtools/client/inspector/markup/test/browser_markup_anonymous_02.js | Edit HTML menu item is disabled -
00:51:09 INFO - TEST-PASS | devtools/client/inspector/markup/test/browser_markup_anonymous_02.js | Paste HTML menu item is disabled -
00:51:09 INFO - TEST-PASS | devtools/client/inspector/markup/test/browser_markup_anonymous_02.js | Child is anonymous -
00:51:09 INFO - TEST-PASS | devtools/client/inspector/markup/test/browser_markup_anonymous_02.js | Child is XBL anonymous -
00:51:09 INFO - TEST-PASS | devtools/client/inspector/markup/test/browser_markup_anonymous_02.js | Child is not shadow anonymous -
00:51:09 INFO - TEST-PASS | devtools/client/inspector/markup/test/browser_markup_anonymous_02.js | Child is not native anonymous -
00:51:09 INFO - Selecting the node for '[Front for domnode/server1.conn6.child1/domnode38]'
00:51:09 INFO - GECKO(3608) | console.log: "[DISPATCH] action type:" "UPDATE_OFFSET_PARENT"
00:51:09 INFO - GECKO(3608) | console.log: "[DISPATCH] action type:" "UPDATE_LAYOUT"
00:51:09 INFO - GECKO(3608) | console.log: "[DISPATCH] action type:" "CLEAR_FLEXBOX"
00:51:09 INFO - TEST-PASS | devtools/client/inspector/markup/test/browser_markup_anonymous_02.js | Delete menu item is disabled -
00:51:09 INFO - TEST-PASS | devtools/client/inspector/markup/test/browser_markup_anonymous_02.js | Edit HTML menu item is disabled -
00:51:09 INFO - TEST-PASS | devtools/client/inspector/markup/test/browser_markup_anonymous_02.js | Paste HTML menu item is disabled -
00:51:09 INFO - TEST-PASS | devtools/client/inspector/markup/test/browser_markup_anonymous_02.js | Child is anonymous -
00:51:09 INFO - TEST-PASS | devtools/client/inspector/markup/test/browser_markup_anonymous_02.js | Child is XBL anonymous -
00:51:09 INFO - TEST-PASS | devtools/client/inspector/markup/test/browser_markup_anonymous_02.js | Child is not shadow anonymous -
00:51:09 INFO - TEST-PASS | devtools/client/inspector/markup/test/browser_markup_anonymous_02.js | Child is not native anonymous -
00:51:09 INFO - Selecting the node for '[Front for domnode/server1.conn6.child1/domnode39]'
00:51:09 INFO - GECKO(3608) | console.log: "[DISPATCH] action type:" "UPDATE_OFFSET_PARENT"
00:51:09 INFO - GECKO(3608) | console.log: "[DISPATCH] action type:" "UPDATE_LAYOUT"
00:51:09 INFO - GECKO(3608) | console.log: "[DISPATCH] action type:" "CLEAR_FLEXBOX"
00:51:09 INFO - TEST-PASS | devtools/client/inspector/markup/test/browser_markup_anonymous_02.js | Delete menu item is disabled -
00:51:09 INFO - TEST-PASS | devtools/client/inspector/markup/test/browser_markup_anonymous_02.js | Edit HTML menu item is disabled -
00:51:09 INFO - TEST-PASS | devtools/client/inspector/markup/test/browser_markup_anonymous_02.js | Paste HTML menu item is disabled -
00:51:09 INFO - Leaving test bound
00:51:09 INFO - GECKO(3608) | console.log: "[DISPATCH] action type:" "UPDATE_OFFSET_PARENT"
00:51:09 INFO - GECKO(3608) | console.log: "[DISPATCH] action type:" "UPDATE_LAYOUT"
00:51:10 INFO - GECKO(3608) | JavaScript error: resource://devtools/shared/protocol.js, line 1299: Error: Connection closed, pending request to server1.conn6.child1/domwalker25, type hasAccessibilityProperties failed
00:51:10 INFO - GECKO(3608) | Request stack:
00:51:10 INFO - GECKO(3608) | request@resource://devtools/shared/protocol.js:1386:14
00:51:10 INFO - GECKO(3608) | generateRequestMethods/</frontProto[name]@resource://devtools/shared/protocol.js:1510:19
00:51:10 INFO - GECKO(3608) | _updateA11YMenuItem@resource://devtools/client/inspector/markup/markup-context-menu.js:767:44
00:51:10 INFO - GECKO(3608) | async*_buildA11YMenuItem@resource://devtools/client/inspector/markup/markup-context-menu.js:364:12
00:51:10 INFO - GECKO(3608) | _openMenu@resource://devtools/client/inspector/markup/markup-context-menu.js:742:10
00:51:10 INFO - GECKO(3608) | openContextMenuAndGetAllItems@chrome://mochitests/content/browser/devtools/client/inspector/test/shared-head.js:663:45
00:51:10 INFO - GECKO(3608) | isEditingMenuDisabled@chrome://mochitests/content/browser/devtools/client/inspector/markup/test/head.js:298:24
00:51:10 INFO - GECKO(3608) | async*@chrome://mochitests/content/browser/devtools/client/inspector/markup/test/browser_markup_anonymous_02.js:29:11
00:51:10 INFO - GECKO(3608) | Async*Tester_execTest/<@chrome://mochikit/content/browser-test.js:1106:34
00:51:10 INFO - GECKO(3608) | async*Tester_execTest@chrome://mochikit/content/browser-test.js:1134:12
00:51:10 INFO - GECKO(3608) | nextTest/<@chrome://mochikit/content/browser-test.js:995:14
00:51:10 INFO - GECKO(3608) | SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:803:59
00:51:10 INFO - Console message: [JavaScript Error: "Error: Connection closed, pending request to server1.conn6.child1/domwalker25, type hasAccessibilityProperties failed
00:51:10 INFO -
00:51:10 INFO - Request stack:
00:51:10 INFO - request@resource://devtools/shared/protocol.js:1386:14
00:51:10 INFO - generateRequestMethods/</frontProto[name]@resource://devtools/shared/protocol.js:1510:19
00:51:10 INFO - _updateA11YMenuItem@resource://devtools/client/inspector/markup/markup-context-menu.js:767:44
00:51:10 INFO - async*_buildA11YMenuItem@resource://devtools/client/inspector/markup/markup-context-menu.js:364:12
00:51:10 INFO - _openMenu@resource://devtools/client/inspector/markup/markup-context-menu.js:742:10
00:51:10 INFO - openContextMenuAndGetAllItems@chrome://mochitests/content/browser/devtools/client/inspector/test/shared-head.js:663:45
00:51:10 INFO - isEditingMenuDisabled@chrome://mochitests/content/browser/devtools/client/inspector/markup/test/head.js:298:24
00:51:10 INFO - async*@chrome://mochitests/content/browser/devtools/client/inspector/markup/test/browser_markup_anonymous_02.js:29:11
00:51:10 INFO - Async*Tester_execTest/<@chrome://mochikit/content/browser-test.js:1106:34
00:51:10 INFO - async*Tester_execTest@chrome://mochikit/content/browser-test.js:1134:12
00:51:10 INFO - nextTest/<@chrome://mochikit/content/browser-test.js:995:14
00:51:10 INFO - SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:803:59
00:51:10 INFO - " {file: "resource://devtools/shared/protocol.js" line: 1299}]
00:51:10 INFO - GECKO(3608) | console.warn: "Error while detaching the thread front: 'detach' request packet to 'server1.conn6.child1/context22' can't be sent as the connection is closed."
00:51:10 INFO - Removing tab.
00:51:10 INFO - Waiting for event: 'TabClose' on [object XULElement].
00:51:10 INFO - Got event: 'TabClose' on [object XULElement].
00:51:10 INFO - Tab removed and finished closing
00:51:10 INFO - TEST-INFO | started process screenshot
00:51:10 INFO - TEST-INFO | screenshot: exit 0
00:51:10 INFO - TEST-UNEXPECTED-FAIL | devtools/client/inspector/markup/test/browser_markup_anonymous_02.js | A promise chain failed to handle a rejection: Connection closed, pending request to server1.conn6.child1/domwalker25, type hasAccessibilityProperties failed
00:51:10 INFO -
00:51:10 INFO - Request stack:
00:51:10 INFO - request@resource://devtools/shared/protocol.js:1386:14
00:51:10 INFO - generateRequestMethods/</frontProto[name]@resource://devtools/shared/protocol.js:1510:19
00:51:10 INFO - _updateA11YMenuItem@resource://devtools/client/inspector/markup/markup-context-menu.js:767:44
00:51:10 INFO - async*_buildA11YMenuItem@resource://devtools/client/inspector/markup/markup-context-menu.js:364:12
00:51:10 INFO - _openMenu@resource://devtools/client/inspector/markup/markup-context-menu.js:742:10
00:51:10 INFO - openContextMenuAndGetAllItems@chrome://mochitests/content/browser/devtools/client/inspector/test/shared-head.js:663:45
00:51:10 INFO - isEditingMenuDisabled@chrome://mochitests/content/browser/devtools/client/inspector/markup/test/head.js:298:24
00:51:10 INFO - async*@chrome://mochitests/content/browser/devtools/client/inspector/markup/test/browser_markup_anonymous_02.js:29:11
00:51:10 INFO - Async*Tester_execTest/<@chrome://mochikit/content/browser-test.js:1106:34
00:51:10 INFO - async*Tester_execTest@chrome://mochikit/content/browser-test.js:1134:12
00:51:10 INFO - nextTest/<@chrome://mochikit/content/browser-test.js:995:14
00:51:10 INFO - SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:803:59
00:51:10 INFO - - stack: destroy@resource://devtools/shared/protocol.js:1299:23
00:51:10 INFO - destroy@resource://devtools/shared/protocol.js:946:17
00:51:10 INFO - destroy@resource://devtools/shared/protocol.js:1301:11
00:51:10 INFO - destroy@resource://devtools/shared/fronts/inspector.js:486:11
00:51:10 INFO - destroyInspector/this._destroyingInspector<@resource://devtools/client/framework/toolbox.js:2857:29
00:51:10 INFO - Async*destroyInspector@resource://devtools/client/framework/toolbox.js:2863:18
00:51:10 INFO - _destroyToolbox@resource://devtools/client/framework/toolbox.js:2964:27
00:51:10 INFO - async*destroy@resource://devtools/client/framework/toolbox.js:2894:28
00:51:10 INFO - closeToolbox@resource://devtools/client/framework/devtools.js:594:19
00:51:10 INFO - async*closeTabAndToolbox@chrome://mochitests/content/browser/devtools/client/shared/test/shared-head.js:453:23
00:51:10 INFO - async*cleanup@chrome://mochitests/content/browser/devtools/client/shared/test/shared-head.js:136:11
00:51:10 INFO - async*nextTest@chrome://mochikit/content/browser-test.js:705:35
00:51:10 INFO - async*testScope/test_finish/<@chrome://mochikit/content/browser-test.js:1407:25
00:51:10 INFO - run@chrome://mochikit/content/browser-test.js:1344:9
00:51:10 INFO - Rejection date: Thu Feb 28 2019 00:51:09 GMT+0000 (Greenwich Mean Time) - false == true - JS frame :: resource://testing-common/PromiseTestUtils.jsm :: assertNoUncaughtRejections :: line 257
00:51:10 INFO - Stack trace:
00:51:10 INFO - resource://testing-common/PromiseTestUtils.jsm:assertNoUncaughtRejections:257
00:51:10 INFO - chrome://mochikit/content/browser-test.js:nextTest:745
00:51:10 INFO - chrome://mochikit/content/browser-test.js:testScope/test_finish/<:1407
00:51:10 INFO - chrome://mochikit/content/browser-test.js:run:1344
00:51:10 INFO - GECKO(3608) | MEMORY STAT | vsize 5874MB | vsizeMaxContiguous 67102417MB | residentFast 282MB | heapAllocated 108MB
00:51:10 INFO - TEST-OK | devtools/client/inspector/markup/test/browser_markup_anonymous_02.js | took 1820ms
00:51:10 INFO - checking window state

Assignee

Updated

3 months ago
Keywords: regression
Comment hidden (Intermittent Failures Robot)
Assignee

Updated

3 months ago
Summary: windows/aarch64 - devtools/client/inspector/markup/test/browser_markup_anonymous_02.js, browser_markup_anonymous_03.js, browser_markup_anonymous_04.js | A promise chain failed to handle a rejection | multiple failures → windows/aarch64 - devtools/client/inspector/markup/test/browser_markup_anonymous_02.js, browser_markup_anonymous_03.js, browser_markup_anonymous_04.js | A promise chain failed to handle a rejection | type hasAccessibilityProperties failed
Assignee

Updated

3 months ago
Blocks: 1533114

Comment 2

3 months ago

Yura, this test wouldn't normally fail in this way, since a11y isn't normally enabled and thus we wouldn't run _updateA11YMenuItem. However, it seems odd to me that this is failing with a11y enabled regardless. Any ideas?

Flags: needinfo?(yzenevich)
Assignee

Comment 3

3 months ago

Depends on D22595

Comment 4

3 months ago
Pushed by egao@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e88f596100e8
disable browser_markup_anonymous_02/03/04.js r=jmaher

Comment 5

3 months ago
bugherder
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
Assignee: nobody → egao
Comment hidden (Intermittent Failures Robot)

(In reply to James Teh [:Jamie] from comment #2)

Yura, this test wouldn't normally fail in this way, since a11y isn't normally enabled and thus we wouldn't run _updateA11YMenuItem. However, it seems odd to me that this is failing with a11y enabled regardless. Any ideas?

Yeah, the reason this is failing is because a11y menu item is the only one that updates asynchronously. It does not fail because of accessibility itself. Test in this environment seems to not wait or update until the operation is complete.

Flags: needinfo?(yzenevich)

Comment 9

2 months ago
Pushed by yura.zenevich@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/31dc14d0b906
catch promise error when updating a11y menu item when DOMWalker connection is already closed. r=gl
Assignee

Comment 10

2 months ago

Once in mozilla-central I can re-enable disabled tests for windows10-aarch64.

You need to log in before you can comment on or make changes to this bug.