Closed Bug 1531585 Opened 10 months ago Closed 9 months ago

[Context Menu] Implement dismiss a story menu option inside pocket new tab

Categories

(Firefox :: New Tab Page, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 67
Iteration:
67.4 - Mar 11 - 17
Tracking Status
firefox67 --- verified
firefox68 --- verified

People

(Reporter: pdahiya, Assigned: pdahiya)

References

Details

(Keywords: github-merged)

Attachments

(1 file)

No description provided.

Scope of this bug is to implement dismiss menu option for Pocket New Tab. See https://bugzilla.mozilla.org/show_bug.cgi?id=1527642#c6

Summary: Implement dismiss a story menu option inside pocket new tab context menu → [Context Menu] Implement dismiss a story menu option inside pocket new tab
Assignee: nobody → pdahiya
Iteration: --- → 67.1 - Jan 28 - Feb 10
Priority: -- → P1
Iteration: 67.1 - Jan 28 - Feb 10 → 67.4 - Mar 11 - 17
Iteration: 67.4 - Mar 11 - 17 → 67.3 - Feb 25 - Mar 10
Iteration: 67.3 - Feb 25 - Mar 10 → 67.4 - Mar 11 - 17

QA Steps

  1. Click context menu button on top right to open context menu
  2. Click of Dismiss link menu option should remove the item from all components on new tab page

Context menu design specs: https://bugzilla.mozilla.org/show_bug.cgi?id=1527642#c5

Duplicate of this bug: 1534845
Keywords: github-merged
Blocks: 1535460
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67

I have verified this issue with the latest Firefox Beta (67.0b9 Build ID - 20190408123043) and with the latest Firefox Nightly (68.0a1 Build ID - 20190410215612) installed, on Windows 10 x64, Arch Linux and Mac 10.13.3. Now, the "Dismiss" option is displayed inside the "Pocket New Tab" context menu and if is selected the card is successfully removed from the "Recommended by Pocket" area.

Status: RESOLVED → VERIFIED
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.