Closed Bug 1531713 Opened 9 months ago Closed 8 months ago

RTAMO - about:welcome's 'Install Extension' window should only be shown once

Categories

(Firefox :: Messaging System, defect, minor)

66 Branch
Desktop
Windows 10
defect
Not set
minor

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox66 --- wontfix
firefox67 --- affected

People

(Reporter: vlad.jiman, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Attached video 2019-03-01_13h46_23.mp4

The RTAMO about:welcome - 'Install Extension' page should only be shown once, however we are currently seeing this page even after closing the browser / tab or choosing to go to the On Boarding tour.

Steps to reproduce:

  1. Uninstall Firefox and remove any remaining data from AppData\Local\Mozilla\Firefox
  2. Using Edge on a clean profile, go to https://addons.mozilla.org/it/firefox/addon/ghostery/ and select to Get Firefox
  3. Install Firefox, then close it
  4. Open a Fx 66b12 or Nightly build and proceed to about:welcome
  5. Close the tab/browser and repeat the last action

Expected:
The Install Extension page should only be shown once

Actual:
The page is available constantly, it will go away once the user chooses to install the given extension however.

Severity: major → minor

about:welcome should be opened automatically during first-run on a fresh install of release. If it re-opens on restart, then there is a bug (unrelated to rtamo).

If the user opens a tab and enters about:welcome into the url bar, they will get the page showing the extension. That is expected.

From comment 1, sounds like this may not be a valid bug since we expect going to about:welcome a second time to show the extension. If that's the case, please close this bug as invalid.

(In reply to Vlad Jiman from comment #0)

Created attachment 9047660 [details]
2019-03-01_13h46_23.mp4

The RTAMO about:welcome - 'Install Extension' page should only be shown once, however we are currently seeing this page even after closing the browser / tab or choosing to go to the On Boarding tour.

Steps to reproduce:

  1. Uninstall Firefox and remove any remaining data from AppData\Local\Mozilla\Firefox
  2. Using Edge on a clean profile, go to https://addons.mozilla.org/it/firefox/addon/ghostery/ and select to Get Firefox
  3. Install Firefox, then close it
  4. Open a Fx 66b12 or Nightly build and proceed to about:welcome
  5. Close the tab/browser and repeat the last action

Expected:
The Install Extension page should only be shown once

Actual:
The page is available constantly, it will go away once the user chooses to install the given extension however.

NI Andrei to see if this is expected (sorry if Newtab is the wrong component, wanted to make sure AS sees it).

Component: General → Activity Streams: Newtab
Flags: needinfo?(andrei.br92)
Product: WebExtensions → Firefox

From (4) it sounds like no action is taken on the RTAMO message (either Cancel or Install). If that's the case then the behavior is expected. We "block" the message after the user takes the first action not after the first impression.

Flags: needinfo?(andrei.br92)

Thank you, I'm going to mark this bug as resolved.

Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → WONTFIX
Component: Activity Streams: Newtab → Messaging System
You need to log in before you can comment on or make changes to this bug.