Closed Bug 1531789 Opened 4 years ago Closed 3 years ago

High frequency toolkit/xre/test/browser_checkdllblockliststate.js | Windows dll blocklist status should be true, indicating it is running properly. A failure in this test is considered a release blocker. -

Categories

(Toolkit :: Startup and Profile System, defect, P5)

Unspecified
Windows
defect

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox67 - disabled
firefox68 - disabled
firefox69 --- disabled
firefox70 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: jimm)

References

(Regression)

Details

(Keywords: intermittent-failure, regression, Whiteboard: [stockwell fixed:backout])

Attachments

(1 file)

#[markdown(off)]
Filed by: ncsoregi [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=231227015&repo=mozilla-central

https://queue.taskcluster.net/v1/task/GEs0nm5nSemsL8IPHHvT5Q/runs/0/artifacts/public/logs/live_backing.log

12:55:59 INFO - TEST-START | toolkit/xre/test/browser_checkdllblockliststate.js
12:55:59 INFO - GECKO(5176) | ### XPCOM_MEM_BLOAT_LOG defined -- logChrome file dging bloat/leaks to c:\users\oesn't exist: Z:\task_15514task38841\_build\tests\mochitest\browser\toolki1551438841\appdata\local\temp\tmpqzmswk.mt\xre\test\head.jso
12:55:59 INFO - GECKO(5176) | zrunner\runtests_leaks_tab_pid2976.log
12:55:59 INFO - GECKO(5176) | DLL blocklist was unable to intercept AppInit DLLs.
12:55:59 INFO - GECKO(5176) | ### XPCOM_MEM_BLOAT_LOG defined -- logging bloat/leaks to c:\users\task_1551438841\appdata\local\temp\tmpqzmswk.mozrunner\runtests_leaks_tab_pid9796.log
12:55:59 INFO - GECKO(5176) | [Parent 6872, Main Thread] WARNING: '!parent', file z:/build/build/src/netwerk/ipc/NeckoParent.cpp, line 957
12:56:00 INFO - GECKO(5176) | [Parent 6872, Main Thread] WARNING: '!parent', file z:/build/build/src/netwerk/ipc/NeckoParent.cpp, line 957
12:56:00 INFO - GECKO(5176) | ++DOCSHELL 0000013CCF975800 == 1 [pid = 2976] [id = {96464d7d-3a1e-4889-b28b-cd64664066e3}]
12:56:00 INFO - GECKO(5176) | ++DOMWINDOW == 1 (0000013CD369E800) [pid = 2976] [serial = 1] [outer = 0000000000000000]
12:56:00 INFO - GECKO(5176) | ++DOCSHELL 0000021DAC675800 == 1 [pid = 9796] [id = {3b1332ae-7775-4c58-b121-618ef855d32e}]
12:56:00 INFO - GECKO(5176) | ++DOMWINDOW == 1 (0000021DB03A9800) [pid = 9796] [serial = 1] [outer = 0000000000000000]
12:56:00 INFO - GECKO(5176) | ++DOMWINDOW == 2 (0000013CD36A1800) [pid = 2976] [serial = 2] [outer = 0000013CD369E800]
12:56:00 INFO - GECKO(5176) | ++DOMWINDOW == 2 (0000021DB03AC800) [pid = 9796] [serial = 2] [outer = 0000021DB03A9800]
12:56:00 INFO - GECKO(5176) | ++DOMWINDOW == 3 (0000013CD4698C00) [pid = 2976] [serial = 3] [outer = 0000013CD369E800]
12:56:00 INFO - GECKO(5176) | ++DOMWINDOW == 3 (0000021DB1395C00) [pid = 9796] [serial = 3] [outer = 0000021DB03A9800]
12:56:00 INFO - TEST-INFO | started process screenshot
12:56:00 INFO - TEST-INFO | screenshot: exit 0
12:56:00 INFO - Buffered messages logged at 12:55:59
12:56:00 INFO - Entering test bound test
12:56:00 INFO - Buffered messages finished
12:56:00 INFO - TEST-UNEXPECTED-FAIL | toolkit/xre/test/browser_checkdllblockliststate.js | Windows dll blocklist status should be true, indicating it is running properly. A failure in this test is considered a release blocker. -
12:56:00 INFO - Stack trace:
12:56:00 INFO - chrome://mochikit/content/browser-test.js:test_ok:1304
12:56:00 INFO - chrome://mochitests/content/browser/toolkit/xre/test/browser_checkdllblockliststate.js:test/<:7
12:56:00 INFO - resource://testing-common/BrowserTestUtils.jsm:withNewTab:111
12:56:00 INFO - chrome://mochitests/content/browser/toolkit/xre/test/browser_checkdllblockliststate.js:test:6
12:56:00 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1106
12:56:00 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1134
12:56:00 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:995
12:56:00 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:803
12:56:00 INFO - Leaving test bound test
12:56:00 INFO - GECKO(5176) | MEMORY STAT | vsize 2103366MB | vsizeMaxContiguous 65141503MB | residentFast 372MB | heapAllocated 114MB
12:56:00 INFO - TEST-OK | toolkit/xre/test/browser_checkdllblockliststate.js | took 1041ms

Component: XUL → Startup and Profile System
Product: Core → Toolkit
Summary: Permafailing tier 2 toolkit/xre/test/browser_checkdllblockliststate.js | Windows dll blocklist status should be true, indicating it is running properly. A failure in this test is considered a release blocker. - → Permafailing tier 2 ccov toolkit/xre/test/browser_checkdllblockliststate.js | Windows dll blocklist status should be true, indicating it is running properly. A failure in this test is considered a release blocker. -

Jim, this test says test failure should be a release blocker. Is that true for win64-ccov?

Flags: needinfo?(jmathies)

If the failure is clang ccov build only then yes I think we can disable it. I poked around clang docs for some information on what they do exactly, didn't find much. But I'm guessing this could slow down execution / much with timing and cause something to load before the dll interceptor kicks in, which would manifest as this failure. Normal builds should still keep this test.

Flags: needinfo?(jmathies)
Pushed by jcristau@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e8b8985aa697
skip browser_checkdllblockliststate.js on win-ccov. r=jmathies
Summary: Permafailing tier 2 ccov toolkit/xre/test/browser_checkdllblockliststate.js | Windows dll blocklist status should be true, indicating it is running properly. A failure in this test is considered a release blocker. - → High frequency toolkit/xre/test/browser_checkdllblockliststate.js | Windows dll blocklist status should be true, indicating it is running properly. A failure in this test is considered a release blocker. -

Re-pinging Jim based on this restarting, now on non-ccov builds (including pgo ones, cf. https://treeherder.mozilla.org/#/jobs?repo=autoland&group_state=expanded&selectedJob=255495055&resultStatus=testfailed%2Cbusted%2Cexception&revision=2799cfb271ca258e9087a16601dd16561bd4a3f3&searchStr=windows ) so timeouts/slowness seem less likely as a possible cause.

Flags: needinfo?(jmathies)

Based on retrigger results from Natalia's comment, this is a regression of bug 1557564

Regressed by: 1557564

Joel, do we backout here?

Flags: needinfo?(jmaher)

I would back out, this is the path we want to take for all regressions that are perma fail or high frequency failures where a root cause is identified.

Flags: needinfo?(jmaher)
Whiteboard: [stockwell fixed:backout]
Assignee: nobody → jcristau
Assignee: jcristau → nobody
Assignee: nobody → gsquelart
Target Milestone: --- → mozilla69

I think Jim is a more appropriate owner of this one, as he approved Julien's fix in April. (I only retriggered it recently from bug 1557564, but that was backed-out over there.)

Assignee: gsquelart → jmathies
OS: Unspecified → Windows
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.