Closed Bug 1531799 Opened 7 months ago Closed 7 months ago

Auto-update of Nightly unexpectedly switched to a fresh profile

Categories

(Toolkit :: Startup and Profile System, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1531160

People

(Reporter: jfkthame, Unassigned)

References

(Blocks 1 open bug)

Details

I have Nightly set as my default browser. Just now allowed it to restart/self-update today (I think it may have been a few days old, not sure of the exact build prior to the update).

To my surprise, it came up with a fresh, empty profile rather than restoring my session.

I realize we're moving to profile-per-install, but I would have at least expected my default browser, when updating itself, to continue using the same profile as before the update.

Mentioned this on IRC, and :kats said "that happened on one of my machines but not another", so it seems like there may be some erratic behavior here.

Blocks: 1474285

Can you check if this is bug 1531227?

Yeah, looks like it. Thanks.

Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1531160
Component: Startup and Profile System → Application Update
Blocks: 1557125
Component: Application Update → Startup and Profile System
You need to log in before you can comment on or make changes to this bug.