Closed Bug 1531801 Opened 6 months ago Closed 6 months ago

Update pdf.js to version 2.2.42

Categories

(Firefox :: PDF Viewer, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 67
Tracking Status
firefox67 --- fixed

People

(Reporter: RyanVM, Assigned: RyanVM)

References

Details

+++ This bug was initially created as a clone of Bug #1529112 +++

Changes since last update:
#10579 Re-factor the PDFSidebar constructor to simplify its call-site (PR 10123 follow-up)
#10578 Try to temporarily hack around the __non_webpack_require__ bug, and update Webpack to the latest stable version (issue 10177)
#10577 Move worker-thread only functions from src/shared/util.js and into a new src/core/core_utils.js file
#10582 Use Promise.prototype.finally in the PDFRenderingQueue.renderView method
#10589 Run the custom_spec unit-tests in Node.js/Travis (PR 10537 follow-up)
#10585 Load built-in CMap files using the Fetch API when possible
#10573 Avoid truncating/breaking some Type3 glyphs in compileType3Glyph (bug 1245391, issue 10568)
#10599 Update Webpack to the latest stable version (4.29.6)
#10597 Ensure that the temporary canvas created in CanvasGraphics.isFontSubpixelAAEnabled will be cleared
#10595 Zero the width/height of the temporary canvas used during JpegDecode (issue 10594)
#10591 Add unique glyph names for CFF fonts.

Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/a9924d5ccbc6
Update pdf.js to version 2.2.42. r=bdahl
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
Blocks: 1532355
Duplicate of this bug: 1524825
You need to log in before you can comment on or make changes to this bug.