Closed Bug 1531839 Opened 10 months ago Closed 10 months ago

Assertion failure: mStart <= mEnd (Invalid Interval), at src/obj-firefox/dist/include/Intervals.h:48

Categories

(Core :: Audio/Video: Playback, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla67
Tracking Status
firefox-esr60 --- wontfix
firefox65 --- wontfix
firefox66 --- wontfix
firefox67 --- fixed

People

(Reporter: tsmith, Assigned: jya)

References

(Blocks 2 open bugs)

Details

(Keywords: assertion, crash, testcase)

Attachments

(2 files)

Attached video testcase.mp4

Assertion failure: mStart <= mEnd (Invalid Interval), at src/obj-firefox/dist/include/Intervals.h:48

#0 Interval<mozilla::media::TimeUnit, mozilla::media::TimeUnit> src/obj-firefox/dist/include/Intervals.h:48:5
#1 mozilla::Index::ConvertByteRangesToTimeRanges(mozilla::media::IntervalSet<long> const&) src/dom/media/mp4/Index.cpp:564
#2 mozilla::MP4TrackDemuxer::GetBuffered() src/dom/media/mp4/MP4Demuxer.cpp:587:18
#3 mozilla::MediaFormatReader::DemuxerProxy::Wrapper::UpdateBuffered() src/dom/media/MediaFormatReader.cpp:882:32
#4 mozilla::MediaFormatReader::DemuxerProxy::Init()::$_10::operator()() const src/dom/media/MediaFormatReader.cpp:929:29
#5 InvokeMethod<(lambda at /builds/worker/workspace/build/src/dom/media/MediaFormatReader.cpp:900:14), RefPtr<mozilla::MozPromise<mozilla::MediaResult, mozilla::MediaResult, true> > ((lambda at /builds/worker/workspace/build/src/dom/media/MediaFormatReader.cpp:900:14)::*)() const, mozilla::MediaResult> src/obj-firefox/dist/include/mozilla/MozPromise.h:510:12
#6 InvokeCallbackMethod<true, (lambda at /builds/worker/workspace/build/src/dom/media/MediaFormatReader.cpp:900:14), RefPtr<mozilla::MozPromise<mozilla::MediaResult, mozilla::MediaResult, true> > ((lambda at /builds/worker/workspace/build/src/dom/media/MediaFormatReader.cpp:900:14)::*)() const, mozilla::MediaResult, RefPtr<mozilla::MozPromise<mozilla::MediaResult, mozilla::MediaResult, true>::Private> > src/obj-firefox/dist/include/mozilla/MozPromise.h:519
#7 mozilla::MozPromise<mozilla::MediaResult, mozilla::MediaResult, true>::ThenValue<mozilla::MediaFormatReader::DemuxerProxy::Init()::$_10, mozilla::MediaFormatReader::DemuxerProxy::Init()::$_11>::DoResolveOrRejectInternal(mozilla::MozPromise<mozilla::MediaResult, mozilla::MediaResult, true>::ResolveOrRejectValue&) src/obj-firefox/dist/include/mozilla/MozPromise.h:716
#8 mozilla::MozPromise<mozilla::MediaResult, mozilla::MediaResult, true>::ThenValueBase::ResolveOrRejectRunnable::Run() src/obj-firefox/dist/include/mozilla/MozPromise.h:392:21
#9 mozilla::TaskQueue::Runner::Run() src/xpcom/threads/TaskQueue.cpp:199:12
#10 nsThreadPool::Run() src/xpcom/threads/nsThreadPool.cpp:241:14
#11 non-virtual thunk to nsThreadPool::Run() src/xpcom/threads/nsThreadPool.cpp
#12 nsThread::ProcessNextEvent(bool, bool*) src/xpcom/threads/nsThread.cpp:1162:14
#13 NS_ProcessNextEvent(nsIThread*, bool) src/xpcom/threads/nsThreadUtils.cpp:475:10
#14 mozilla::ipc::MessagePumpForNonMainThreads::Run(base::MessagePump::Delegate*) src/ipc/glue/MessagePump.cpp:303:20
#15 RunInternal src/ipc/chromium/src/base/message_loop.cc:315:10
#16 RunHandler src/ipc/chromium/src/base/message_loop.cc:308
#17 MessageLoop::Run() src/ipc/chromium/src/base/message_loop.cc:290
#18 nsThread::ThreadFunc(void*) src/xpcom/threads/nsThread.cpp:449:11
Flags: in-testsuite?
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1531891
Duplicate of bug: 1531241
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Assignee: nobody → jyavenard
See Also: → 1531241

It usually is, but obviously, not always.

Include reversal of bug 1531241.

Duplicate of this bug: 1531953
Blocks: 1531991
Pushed by jyavenard@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/52fc794e22ee
Don't assume that MP4 blocks are in pts order. r=gerald
Status: REOPENED → RESOLVED
Closed: 10 months ago10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67

Can we land this testcase as a crashtest?

Flags: needinfo?(jyavenard)

(In reply to Ryan VanderMeulen [:RyanVM] from comment #7)

Can we land this testcase as a crashtest?

see bug 1531991

Flags: needinfo?(jyavenard)
You need to log in before you can comment on or make changes to this bug.