Drag and drop multiple mails can drop in wrong folder

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
--
major
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: Rob Napier, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1a) Gecko/20020611
BuildID:    2002061104

Selecting multiple mails and dragging them to a folder (in this case from an
IMAP folder to a local folder) sometimes acts as though I've let go of the mouse
button and re-clicked it. To wit, the mail drops in the wrong folder and I then
find myself dragging some other folder (not the one that the mail was dropped into).

At first I assumed that I was in fact unclicking and reclicking accidentally,
but I have tried this repeatedly, carefully forcing the button down, and
repeatedly had this problem.

Reproducible: Sometimes
Steps to Reproduce:
1. Select multiple mails (in my experience from an IMAP folder)
2. Drag over a large number of folders in the folder pane (I probably cross over
20 or so folders, some of them nested 1 deep)


Actual Results:  1. The mails will drop into a "random" (haven't determined
pattern) folder and I "pick up" another "random" folder.
2. When I unclick at my destination, the second "random" folder is moved there.

Expected Results:  Mails should drop into destination.

I've raised this to Major because it has caused me to repeatedly lose mails
among my several dozen folders. No data is actually lost, but it is very
possible to "misplace" data such that you are unlikely to find it again (given
the size of some of my folders).

Updated

16 years ago
QA Contact: olgam → gchan

Comment 1

16 years ago
Reporter,
Using trunk build:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1a) Gecko/20020619

I am able to drag mutiple mesgs (say 10) over mutliple folders and
mail accounts. And I don't lose them till I get to my destination
folder (a folder under Local Accounts). They aren't accidentally
droped into another folder.

I think you are running into bug 150716, which was fixed on June 13.
That bug had problem with 'moving/dragging' multiple messages.
Since you reported your bug with june 11th, I'm guessing your running
into that bug.

So if you could try a more current trunk build and see if you still
run into this problem, it would be appreciated.

Comment 2

16 years ago
Resolving as we had no reply from reporter.
Reporter, if you still have this issue in a current build, please reopen and
comment with details.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.