Intermittent TEST-UNEXPECTED-TIMEOUT | /dom/events/Event-dispatch-on-disabled-elements.html | CSS Animation events fire on disabled form elements - Test timed out

RESOLVED FIXED in Firefox 67

Status

()

defect
P2
normal
RESOLVED FIXED
4 months ago
2 months ago

People

(Reporter: intermittent-bug-filer, Assigned: marcosc)

Tracking

({intermittent-failure, regression})

unspecified
mozilla67
Points:
---

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox65 unaffected, firefox66 unaffected, firefox67 fixed)

Details

(Whiteboard: [stockwell disable-recommended][wptsync upstream])

Attachments

(1 attachment)

Reporter

Description

4 months ago
treeherder

#[markdown(off)]
Filed by: ncsoregi [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=231597674&repo=autoland

https://queue.taskcluster.net/v1/task/UqFK4VrRTPKg4udBQH1Xvw/runs/0/artifacts/public/logs/live_backing.log

[task 2019-03-04T04:48:21.378Z] 04:48:21 INFO - PID 4141 | --DOMWINDOW == 53 (0xdc13d840) [pid = 4141] [serial = 69] [outer = (nil)] [url = http://web-platform.test:8000/dom/events/Event-dispatch-bubbles-false.html]
[task 2019-03-04T04:48:21.378Z] 04:48:21 INFO - PID 4141 | --DOMWINDOW == 52 (0xdc13d710) [pid = 4141] [serial = 65] [outer = (nil)] [url = http://web-platform.test:8000/dom/events/Event-dispatch-bubble-canceled.html]
[task 2019-03-04T04:48:21.380Z] 04:48:21 INFO - PID 4141 | --DOCSHELL 0xdc732000 == 14 [pid = 4141] [id = {11b9806b-b687-4397-8c20-c8304b8bc4cf}]
[task 2019-03-04T04:48:21.380Z] 04:48:21 INFO - PID 4141 | --DOCSHELL 0xdc1b8800 == 13 [pid = 4141] [id = {750d90ba-b5ce-47ea-8f89-92f99dcb253b}]
[task 2019-03-04T04:48:21.380Z] 04:48:21 INFO - PID 4141 | --DOCSHELL 0xdfa89800 == 12 [pid = 4141] [id = {23b7a6e9-26d2-4c3a-bf42-3fd95aa4e768}]
[task 2019-03-04T04:48:21.381Z] 04:48:21 INFO - PID 4141 | --DOCSHELL 0xdc1bb400 == 11 [pid = 4141] [id = {9cf33ed9-d0e7-467f-bff6-4a34af3e2a45}]
[task 2019-03-04T04:48:24.710Z] 04:48:24 INFO -
[task 2019-03-04T04:48:24.710Z] 04:48:24 INFO - TEST-PASS | /dom/events/Event-dispatch-on-disabled-elements.html | Can dispatch untrusted 'click' Events at disabled HTML elements.
[task 2019-03-04T04:48:24.710Z] 04:48:24 INFO - TEST-PASS | /dom/events/Event-dispatch-on-disabled-elements.html | Can dispatch untrusted Events at disabled HTML elements.
[task 2019-03-04T04:48:24.711Z] 04:48:24 INFO - TEST-PASS | /dom/events/Event-dispatch-on-disabled-elements.html | Can dispatch CustomEvents at disabled HTML elements.
[task 2019-03-04T04:48:24.711Z] 04:48:24 INFO - TEST-PASS | /dom/events/Event-dispatch-on-disabled-elements.html | Calling click() on disabled elements must not dispatch events.
[task 2019-03-04T04:48:24.711Z] 04:48:24 INFO - TEST-PASS | /dom/events/Event-dispatch-on-disabled-elements.html | CSS Transitions events fire on disabled form elements
[task 2019-03-04T04:48:24.711Z] 04:48:24 INFO - TEST-UNEXPECTED-TIMEOUT | /dom/events/Event-dispatch-on-disabled-elements.html | CSS Animation events fire on disabled form elements - Test timed out
[task 2019-03-04T04:48:24.712Z] 04:48:24 INFO -
[task 2019-03-04T04:48:24.712Z] 04:48:24 INFO - TEST-UNEXPECTED-NOTRUN | /dom/events/Event-dispatch-on-disabled-elements.html | CSS Animation's cancel events fire on disabled form elements - expected PASS
[task 2019-03-04T04:48:24.712Z] 04:48:24 INFO -
[task 2019-03-04T04:48:24.713Z] 04:48:24 INFO - TEST-UNEXPECTED-NOTRUN | /dom/events/Event-dispatch-on-disabled-elements.html | Real clicks on disabled elements must not dispatch events. - expected PASS
[task 2019-03-04T04:48:24.713Z] 04:48:24 INFO - TEST-UNEXPECTED-TIMEOUT | /dom/events/Event-dispatch-on-disabled-elements.html | expected OK
[task 2019-03-04T04:48:24.713Z] 04:48:24 INFO - TEST-INFO took 30618ms
[task 2019-03-04T04:48:24.749Z] 04:48:24 INFO - PID 4141 | 1551674904739 Marionette INFO Stopped listening on port 2828
[task 2019-03-04T04:48:25.694Z] 04:48:25 INFO - PID 4141 | [4141, Main Thread] WARNING: NS_ENSURE_TRUE(mDB) failed: file /builds/worker/workspace/build/src/netwerk/cache/nsDiskCacheDeviceSQL.cpp, line 1285

Comment hidden (Intermittent Failures Robot)

Hi Marcos, since you fixed bug 1531567 which looks related, care to take a look at this?

Flags: needinfo?(mcaceres)
Assignee

Comment 3

3 months ago

This one should have been fixed together with the other one, but I can’t remember how to check if there have been any new reported failures. You wouldn’t happen to know?

Flags: needinfo?(mcaceres)
Comment hidden (Intermittent Failures Robot)
Assignee

Comment 5

3 months ago

Got my answer ^^^. Will check what’s going on.

Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Priority: -- → P2
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Component: DOM → DOM: Core & HTML
Comment hidden (Intermittent Failures Robot)
Assignee

Comment 11

3 months ago

try to extend the animation time. I tested this locally on repeat 50 times.

Assignee

Updated

3 months ago
Assignee: nobody → mcaceres

Comment 14

3 months ago
Pushed by mcaceres@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a7d81b7bc493
Intermittent TEST-UNEXPECTED-TIMEOUT in Event-dispatch-on-disabled-elements.html r=birtles
Comment hidden (Intermittent Failures Robot)

Comment 16

3 months ago
bugherder
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Comment hidden (Intermittent Failures Robot)
Assignee

Comment 18

3 months ago

No failures since merged.

Whiteboard: [stockwell disable-recommended] → [stockwell disable-recommended][wptsync upstream error]
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/16260 for changes under testing/web-platform/tests
Whiteboard: [stockwell disable-recommended][wptsync upstream error] → [stockwell disable-recommended][wptsync upstream]
You need to log in before you can comment on or make changes to this bug.