Closed Bug 1532231 Opened 9 months ago Closed 8 months ago

DNSRequestChild is not released when the request is done

Categories

(Core :: Networking: DNS, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla67
Tracking Status
firefox67 --- fixed

People

(Reporter: kershaw, Assigned: kershaw)

Details

(Whiteboard: [necko-triaged])

Attachments

(1 file)

When a DNSRequest is completed, ChildDNSService::NotifyRequestDone will be called to remove the request. But the problem is at [1], the request will not be removed when nsTArray::IndexOf returns 0.

[1] https://searchfox.org/mozilla-central/rev/92d11a33250a8e368c8ca3e962e15ca67117f765/netwerk/dns/ChildDNSService.cpp#318

Pushed by kjang@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c2cef5dac595
Properly check if a DNSRequest is in array r=dragana
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
You need to log in before you can comment on or make changes to this bug.