Closed Bug 1532245 Opened 9 months ago Closed 8 months ago

Youtube video is not played on GeckoView_example

Categories

(Core :: Graphics: WebRender, defect)

Unspecified
Android
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla67
Tracking Status
firefox67 --- fixed

People

(Reporter: sotaro, Assigned: tnikkel)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [geckoview:p1])

Attachments

(2 files)

When I tried to play youtube video on GeckoView_example, but the video was not rendered nor played.

OS: Unspecified → Android
Blocks: wr-android
Whiteboard: [geckoview:p1]
Summary: Youtube video is not played on GeckoView_example when multiprocess is enabled → Youtube video is not played on GeckoView_example at first time
Summary: Youtube video is not played on GeckoView_example at first time → Youtube video is not played on GeckoView_example at first time after install
Summary: Youtube video is not played on GeckoView_example at first time after install → Youtube video is not played on GeckoView_example
Attachment #9049091 - Attachment description: error_log during visiting youtube → error log during visiting youtube

From attachment 9049091 [details], shader compilation of brush_blend seemed to be failed.

Nested switch in brush_blend.glsl caused the shader compilation failure.

https://searchfox.org/mozilla-central/source/gfx/wr/webrender/res/brush_blend.glsl#223

(In reply to Sotaro Ikeda [:sotaro] from comment #3)

Nested switch in brush_blend.glsl caused the shader compilation failure.

https://searchfox.org/mozilla-central/source/gfx/wr/webrender/res/brush_blend.glsl#223

It was added by Bug 1505871.

Blocks: 1505871

:tnikkel, can you look into the bug?

Flags: needinfo?(tnikkel)

Hmm, I couldn't reproduce on a Pixel 2. I double checked that webrender was enabled in about:support. I'm guessing different gpu or gpu drivers could explain that (since it works on desktop).

Here's some info from my logcat that might be relevant:
Adreno : QUALCOMM build : 6fb5a5b, Ife855c4895
Adreno : Build Date : 08/21/18
Adreno : OpenGL ES Shader Compiler Version: EV031.25.00.00
Adreno : Local Branch : Googledrop_0815
Adreno : Remote Branch :
Adreno : Remote Branch :
Adreno : Reconstruct Branch :
Adreno : Build Config : S L 4.0.10 AArch64
Adreno : PFP: 0x005ff110, ME: 0x005ff066

Sotaro, could you try this patch to see if it fixes the issue for you?

https://hg.mozilla.org/try/rev/79f2c3e1b29be89c533cffb93ef5f72aa1b47824

try link for that patch
https://treeherder.mozilla.org/#/jobs?repo=try&revision=a991fc05b14eae4207a57c654ea5043301d68491

Flags: needinfo?(tnikkel) → needinfo?(sotaro.ikeda.g)

Thanks! The patch works for me :)

Flags: needinfo?(sotaro.ikeda.g)

Some phones can't compile the shader as is: "ERROR: 0:1448: '' : No default label can be nested inside other control flow nested within their corresponding switch"

Assignee: nobody → tnikkel

(In reply to Sotaro Ikeda [:sotaro] from comment #7)

Thanks! The patch works for me :)

Thanks for testing.

Pushed by tnikkel@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/c32dcf4e6f92
Factor out component transfer code to a function in brush_blend shader for webreder. r=gw

Backed out changeset c32dcf4e6f92 (bug 1532245) for wrench failures

Backout: https://hg.mozilla.org/integration/mozilla-inbound/rev/62bce3145e7e880291d3ec81cfc3e6faa0501a6b

Failure push: https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&resultStatus=superseded%2Ctestfailed%2Cbusted%2Cexception%2Crunnable&revision=c32dcf4e6f92de2e9523312a41fa71b77503f7e2&selectedJob=233230589

Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=233230570&repo=mozilla-inbound

[task 2019-03-11T22:19:23.353Z] 12: 0x559b4ffdb369 - __rust_maybe_catch_panic
[task 2019-03-11T22:19:23.353Z] at src/libpanic_unwind/lib.rs:102
[task 2019-03-11T22:19:23.353Z] 13: 0x559b4fdc30b3 - std::sys_common::backtrace::__rust_begin_short_backtrace::h65c195ad031fb1f0
[task 2019-03-11T22:19:23.353Z] at /rustc/9fda7c2237db910e41d6a712e9a2139b352e558b/src/libstd/panicking.rs:289
[task 2019-03-11T22:19:23.353Z] at /rustc/9fda7c2237db910e41d6a712e9a2139b352e558b/src/libstd/panic.rs:398
[task 2019-03-11T22:19:23.353Z] at src/libtest/lib.rs:1426
[task 2019-03-11T22:19:23.353Z] at /rustc/9fda7c2237db910e41d6a712e9a2139b352e558b/src/libstd/sys_common/backtrace.rs:136
[task 2019-03-11T22:19:23.353Z] 14: 0x559b4fdc3f64 - std::panicking::try::do_call::h066a6115982fd31a
[task 2019-03-11T22:19:23.353Z] at /rustc/9fda7c2237db910e41d6a712e9a2139b352e558b/src/libstd/thread/mod.rs:477
[task 2019-03-11T22:19:23.353Z] at /rustc/9fda7c2237db910e41d6a712e9a2139b352e558b/src/libstd/panic.rs:319
[task 2019-03-11T22:19:23.353Z] at /rustc/9fda7c2237db910e41d6a712e9a2139b352e558b/src/libstd/panicking.rs:310
[task 2019-03-11T22:19:23.353Z] 15: 0x559b4ffdb369 - __rust_maybe_catch_panic
[task 2019-03-11T22:19:23.353Z] at src/libpanic_unwind/lib.rs:102
[task 2019-03-11T22:19:23.353Z] 16: 0x559b4fdcb08c - <F as alloc::boxed::FnBox<A>>::call_box::h4d8606d9fba2ffef
[task 2019-03-11T22:19:23.353Z] at /rustc/9fda7c2237db910e41d6a712e9a2139b352e558b/src/libstd/panicking.rs:289
[task 2019-03-11T22:19:23.353Z] at /rustc/9fda7c2237db910e41d6a712e9a2139b352e558b/src/libstd/panic.rs:398
[task 2019-03-11T22:19:23.353Z] at /rustc/9fda7c2237db910e41d6a712e9a2139b352e558b/src/libstd/thread/mod.rs:476
[task 2019-03-11T22:19:23.353Z] at /rustc/9fda7c2237db910e41d6a712e9a2139b352e558b/src/liballoc/boxed.rs:673
[task 2019-03-11T22:19:23.353Z] 17: 0x559b4ffcf2ed - std::sys::unix::thread::Thread::new::thread_start::hca8e72c41fa9d291
[task 2019-03-11T22:19:23.353Z] at /rustc/9fda7c2237db910e41d6a712e9a2139b352e558b/src/liballoc/boxed.rs:683
[task 2019-03-11T22:19:23.353Z] at src/libstd/sys_common/thread.rs:24
[task 2019-03-11T22:19:23.353Z] at src/libstd/sys/unix/thread.rs:90
[task 2019-03-11T22:19:23.353Z] 18: 0x7f0975d154a3 - start_thread
[task 2019-03-11T22:19:23.353Z] 19: 0x7f0975840d0e - __clone
[task 2019-03-11T22:19:23.353Z] 20: 0x0 - <unknown>
[task 2019-03-11T22:19:23.353Z]
[task 2019-03-11T22:19:23.353Z]
[task 2019-03-11T22:19:23.353Z] failures:
[task 2019-03-11T22:19:23.353Z] validate_shaders
[task 2019-03-11T22:19:23.353Z]
[task 2019-03-11T22:19:23.353Z] test result: FAILED. 0 passed; 1 failed; 0 ignored; 0 measured; 0 filtered out
[task 2019-03-11T22:19:23.353Z]
[task 2019-03-11T22:19:23.355Z] error: test failed, to rerun pass '-p webrender --test angle_shader_validation'
[taskcluster 2019-03-11 22:19:23.671Z] === Task Finished ===
[taskcluster 2019-03-11 22:19:23.671Z] Unsuccessful task run with exit code: 101 completed in 715.111 seconds

Flags: needinfo?(tnikkel)
Pushed by tnikkel@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/bb76bbd404c0
Factor out component transfer code to a function in brush_blend shader for webreder. r=gw
Flags: needinfo?(tnikkel)
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
You need to log in before you can comment on or make changes to this bug.