Kiosk lockdown support.

VERIFIED DUPLICATE of bug 3341

Status

SeaMonkey
UI Design
P3
enhancement
VERIFIED DUPLICATE of bug 3341
19 years ago
13 years ago

People

(Reporter: CodeMachine, Assigned: Samir Gehani)

Tracking

({helpwanted})

Trunk
Future
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
This is a request for the ability to prevent any changes to the UI for "kiosks".
 A possibility for kiosks is to just have an NGLayout widget, but you might want
more, eg personal, url toolbars, bookmarks, etc.

A lot could be achieved through a "kiosk" chrome, see bug #14969 for more
details.  However, there are more things needed.

For example, there are "soft" UI changes.  These are changes which I believe
shouldn't and I don't believe currently do affect the XUL, but which can be made
by the user and remembered.

These include the ability to edit the personal toolbar via DND, whether the
sidebar appears, whether the toolbars are collapsed and whether they appear.
Even if they don't currently save their setting, they should at least be able to
so this is still relevant.

Proposed soft changes include bug #15144 (ability to remove toolbar buttons) and
bug #15322 (ability to reorder toolbars).

So all of these should be able to be disabled in the preferences under a
"Prevent Soft UI Changes".

So basically you need to watch out for implicit ways of changing the UI, since
everything else can probably be explicitly ruled out.  Another to watch out for
is bug #12303, the ability to change the skin from the windows titlebar menu,
and you'd probably also want to remove the Win95 close button (can you do this
under XUL?)
(Reporter)

Comment 1

19 years ago
Oh, I should have mentioned, of course, that the titlebar issues go away if you
have a full screen mode, bug #3341.

Updated

19 years ago
Summary: Kiosk lockdown support. → [RFE] Kiosk lockdown support.

Comment 2

19 years ago
marking RFE
(Reporter)

Comment 3

19 years ago
You would need to take care to remove all "remember this decision" facilities,
including those listed in bug #7380.
(Reporter)

Comment 4

19 years ago
Or at least, only make them last this session?  But can you ensure users log
out?

Comment 5

19 years ago
Don, can you take care of this?

Updated

19 years ago
Target Milestone: M14

Comment 6

19 years ago
Move to M20.

Comment 7

18 years ago
Move to "Future" milestone.
Target Milestone: M20 → Future

Updated

18 years ago
Assignee: don → vishy
Since Don has left, Vishy is taking his bugs in bulk, pending reassignment.
thanks,
	Vishy

Comment 9

18 years ago
leger is no longer @netscape.com
changing qa contact to default for this component
QA Contact: leger → doronr
bug 3341 has become kiosk mode.  bug 68136 is now full-screen mode.

I feel that this should be a duplicate of 3341.  If you do mark it a duplicate,
please transfer the first comment with its bug citations to 3341.

Updated

18 years ago
Component: Browser-General → XP Apps
Depends on: 3341
Keywords: helpwanted
QA Contact: doronr → sairuh
QA Contact: sairuh → claudius

Comment 11

17 years ago
How much longer until this is functional?  This ticket is almost 2 years old.
This bug is marked to Future. That means that the owner (I) do not intend to 
work on it in any foreseen timeframe. 

Comment 13

16 years ago
Reassigning to a real person.
Assignee: vishy → sgehani
QA Contact: claudius → paw

Updated

16 years ago
Summary: [RFE] Kiosk lockdown support. → Kiosk lockdown support.

*** This bug has been marked as a duplicate of 3341 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 15

14 years ago
v
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.