VERY bad hover behavior from self-terminating anchor tags

VERIFIED DUPLICATE of bug 143676

Status

()

Core
CSS Parsing and Computation
--
critical
VERIFIED DUPLICATE of bug 143676
16 years ago
16 years ago

People

(Reporter: Keith Briscoe, Assigned: dbaron)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
I'm using the Linux nightly 1.0 branch build 2002062007.

This is an UGLY bug, but I'm not sure how visible it is.  I'm not sure how many
sites have this problem, but it seems like it could be common enough and it
makes Mozilla look very bad.

If you define a a:hover behavior (underlining, for example), self-terminating
anchors which contain no text will overflow into the follwing text, causing
unrelated (possibly large) parts of the page to get underlined.  This behavior
does NOT occur of the anchor tags is closed the old-fashioned way.

See the test page: http://www.nwlink.com/~cheeth/

The links should underline as you hover.  Neither of the paragraphs underneath
should underline as you hover, but the first one does anyway.
(Assignee)

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 143676 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
The document is served as text/html, so the XML rules about <foo /> do not
apply.    See appendix C of the XHTML spec, which explicitly says that for a
document to be labeled text/html this syntax must not be used for container tags.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

16 years ago
Thanks as usual Boris.  You catch more errors than the W3C validator.  Actually,
using a[href]:hover in the CSS is a simpler solution.

Although it's a tough switch to make, I do appreciate that Moz actually doesn't
play fast and loose with the standards.  Keep up the good work.
You need to log in before you can comment on or make changes to this bug.