Search widget launches Fennec without focusing address bar (every other time)

VERIFIED FIXED in Firefox 67

Status

()

defect
VERIFIED FIXED
3 months ago
2 months ago

People

(Reporter: abovens, Assigned: petru)

Tracking

(Blocks 1 bug)

Firefox 66
Firefox 67
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox66 wontfix, firefox67 verified)

Details

Attachments

(1 attachment)

Reporter

Description

3 months ago
  1. Install the search widget.
  2. Go to the Android Home screen
  3. Tap on the Search box to launch Fennec
  4. New tab is opened, address bar is focused and keyboard is shown (as expected)
  5. Without doing anything else, tap on Home button to show Home screen
  6. Tap on the Search box to launch Fennec again

Expected behavior:
New tab is opened, address bar is focused and keyboard is shown (just like the first time)

Actual behavior:
New tab is opened, but address bar is not focused and no keyboard is shown.

(this only appears to happen every other time)

Assignee

Updated

3 months ago
Assignee: nobody → petru.lingurar
Status: NEW → ASSIGNED
Assignee

Comment 1

3 months ago

We'll delay entering editing mode until we are sure the process for adding a
new "about:home" tab completed.
This allows avoiding certain race conditions with the previous state or with
the tab counter animation.

Updated

3 months ago
Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
Assignee

Updated

3 months ago
Flags: qe-verify+
Assignee

Updated

3 months ago
Group: mozilla-employee-confidential

Seeing that this search widget was such a super-secret project and I've only now stumbled across it - you do know that Tabs.java has a LOADURL_START_EDITING flag and that the procedure in comment 0 is already working fine for ACTION_ASSIST intents?
I can't shake the feeling that you've just duplicated quite a bit of existing functionality - the only bit that would have had to be added was to handle launching voice input, too, depending on the intent...

Flags: needinfo?(petru.lingurar)
Assignee

Comment 5

2 months ago

Hey Jan,

Thanks for chiming in.
Regarding the confidential status of the tickets, that was set just because initially it wasn't really clear what the feature would look like and Product wanted to keep the main ticket clean.
We would've loved your input, it was just an overlook from our side given the confidential status of the tickets (because they were branched out from that confidential meta) and the need to act fast once we had some clear specifications.
Regarding that flag, we actually tried using it but found some edgecases regarding the cold/warm start of the app, so we went with a separate implementation which for our use-case seems to fit like a glove.

Flags: needinfo?(petru.lingurar)

but found some edgecases regarding the cold/warm start of the app

Other than the added voice input handling, the widget seems to have ended up with the basically same functionality as ACTION_ASSIST, though. So depending on what those edge cases precisely were, it might have been worth fixing them anyway, so that ACTION_ASSIST behaves the same as opening a "search tab" through the widget.

Verified as fixed in the latest Nightly build 67.0a1 with Google Pixel 3 XL.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
OS: Unspecified → Android
Hardware: Unspecified → ARM
You need to log in before you can comment on or make changes to this bug.