Keyboard with Enter key is not available after speech input

VERIFIED FIXED

Status

()

defect
VERIFIED FIXED
5 months ago
4 months ago

People

(Reporter: abovens, Assigned: petru)

Tracking

(Blocks 1 bug)

Firefox 66
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox66 wontfix, firefox67 verified)

Details

  1. Install search widget on Home screen
  2. Go to Home screen
  3. Press microphone button on installed search widget
  4. Say "test 123"

Expected result:
The string "test 123" is placed in the address bar and the keyboard is shown, so that I can hit enter to proceed with my search.

Actual result:
The string "test 123" is placed in the address bar and no keyboard is shown.

Note: these steps to reproduce are also affected by bug 1532613.

Assignee: nobody → petru.lingurar
Status: NEW → ASSIGNED

Should have been fixed by bug 1532613.

Flags: qe-verify+
Group: mozilla-employee-confidential

I wasn't able to reproduce the issue by following the steps. But if I first opened up the browser, waited for search widget prompt to appear, pressed the microphone button from the search widget on the home page, said "test123" and dismissed the search widget from the browser, the keyboard indeed is not shown.

The Leanplum experiment was misconfigured so I updated the config and now the dialog should be shown only for the people that hadn't added the widget yet.
Can you please confirm that this doesn't repro anymore?

Flags: needinfo?(levente.sacal)

I can confirm that I can't repro this anymore.

Flags: needinfo?(levente.sacal)
Flags: qe-verify+
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → INVALID

Verified as fixed in the latest Nightly build 67.0a1 with Samsung Galaxy Note 9(Android 8.1.0).
Note that after the text is entered in the URL bar the keyboard will appear but all the text will be selected. This seems to be also the previous behavior that is happening whenever you use the microphone to enter the URL.

Status: RESOLVED → VERIFIED
OS: Unspecified → Android
Hardware: Unspecified → ARM
Resolution: INVALID → FIXED
You need to log in before you can comment on or make changes to this bug.