Picture in Picture mode video doesn't work with videos with a "poster" attribute

RESOLVED FIXED in Firefox 67

Status

()

defect
P1
normal
RESOLVED FIXED
3 months ago
3 months ago

People

(Reporter: alice0775, Assigned: mconley)

Tracking

({nightly-community})

Trunk
mozilla67
x86_64
Windows 10
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox67 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

3 months ago

Build ID 20190305092747
User Agent Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

Reproducible: only certain video with/without WebRender

Steps to reproduce:

  1. enable media.videocontrols.picture-in-picture.enabled
  2. Visit https://www.mozilla.org/en-US/contribute/ and playback
  3. Right click on video, choose Picture in Picture

Actual Results:
Video pops out, but video would not playback.
Only placeholder image is displayed.

Expected Result:
Video should be continue playing.

Comment 1

3 months ago

Surfacing this for Mike to look at and prioritize. :-)

Blocks: 1521954
Flags: needinfo?(mconley)
Priority: -- → P1
Assignee

Updated

3 months ago
Assignee: nobody → mconley
Flags: needinfo?(mconley)
Assignee

Updated

3 months ago
Summary: Picture in Picture mode video would not playback → Picture in Picture mode video doesn't work with videos with a "poster" attribute

Comment 3

3 months ago
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9a94bd3da98f
Clear poster attributes from videos that we're cloning to visually. r=jya
Assignee

Comment 5

3 months ago

Looking.

Flags: needinfo?(mconley)
Assignee

Comment 6

3 months ago

Waiting for the pause event seems to be sufficient, at least according to https://treeherder.mozilla.org/#/jobs?repo=try&revision=5098de1641eb650f1b0f6988db77405f9b3dc27a.

Re-landing.

Comment 7

3 months ago
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5833aea8a83b
Clear poster attributes from videos that we're cloning to visually. r=jya

Comment 8

3 months ago
bugherder
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
You need to log in before you can comment on or make changes to this bug.