Closed Bug 1532695 Opened 9 months ago Closed 7 months ago

Android builds do not produce target.gtest.tests.tar.gz

Categories

(Firefox Build System :: General, enhancement)

enhancement
Not set

Tracking

(firefox68 fixed)

RESOLVED FIXED
mozilla68
Tracking Status
firefox68 --- fixed

People

(Reporter: gbrown, Assigned: gbrown)

References

Details

Attachments

(1 file)

Linux (and other desktop) builds produce target.gtest.tests.tar.gz, but Android builds do not.

(That makes sense because gtest doesn't run on Android currently...but now we want to.)

Android:

[task 2019-03-05T10:31:16.447Z] 10:31:16 INFO - package-tests> /builds/worker/workspace/build/src/obj-firefox/_virtualenvs/init/bin/python /builds/worker/workspace/build/src/build/gen_test_packages_manifest.py
[task 2019-03-05T10:31:16.447Z] 10:31:16 INFO - package-tests> --jsshell target.jsshell.zip
[task 2019-03-05T10:31:16.447Z] 10:31:16 INFO - package-tests> --dest-file 'dist//target.test_packages.json'
[task 2019-03-05T10:31:16.447Z] 10:31:16 INFO - package-tests> --common 'target.common.tests.zip'
[task 2019-03-05T10:31:16.447Z] 10:31:16 INFO - package-tests> --common 'target.common.tests.tar.gz' --cppunittest 'target.cppunittest.tests.tar.gz' --mochitest 'target.mochitest.tests.tar.gz' --reftest 'target.reftest.tests.tar.gz' --talos 'target.talos.tests.tar.gz' --raptor 'target.raptor.tests.tar.gz' --awsy 'target.awsy.tests.tar.gz' --xpcshell 'target.xpcshell.tests.tar.gz' --web-platform 'target.web-platform.tests.tar.gz' --updater-dep 'target.updater-dep.tests.tar.gz'

Linux:

[task 2019-03-05T10:01:14.984Z] 10:01:14 INFO - package-tests> /builds/worker/workspace/build/src/obj-firefox/_virtualenvs/init/bin/python /builds/worker/workspace/build/src/build/gen_test_packages_manifest.py
[task 2019-03-05T10:01:14.984Z] 10:01:14 INFO - package-tests> --jsshell target.jsshell.zip
[task 2019-03-05T10:01:14.984Z] 10:01:14 INFO - package-tests> --dest-file 'dist//target.test_packages.json'
[task 2019-03-05T10:01:14.984Z] 10:01:14 INFO - package-tests> --common 'target.common.tests.zip'
[task 2019-03-05T10:01:14.984Z] 10:01:14 INFO - package-tests> --common 'target.common.tests.tar.gz' --cppunittest 'target.cppunittest.tests.tar.gz' --mochitest 'target.mochitest.tests.tar.gz' --reftest 'target.reftest.tests.tar.gz' --talos 'target.talos.tests.tar.gz' --raptor 'target.raptor.tests.tar.gz' --awsy 'target.awsy.tests.tar.gz' --xpcshell 'target.xpcshell.tests.tar.gz' --web-platform 'target.web-platform.tests.tar.gz' --updater-dep 'target.updater-dep.tests.tar.gz' --gtest 'target.gtest.tests.tar.gz'

https://searchfox.org/mozilla-central/rev/3e0f1d95fcf8832413457e3bec802113bdd1f8e8/testing/testsuite-targets.mk#142

I suppose gtest is missing from TEST_PKGS_TARGZ because !LINK_GTEST_DURING_COMPILE

https://searchfox.org/mozilla-central/rev/3e0f1d95fcf8832413457e3bec802113bdd1f8e8/testing/testsuite-targets.mk#128-131

Verified that issue here and successfully generated target.gtests.tar.gz for android:

https://treeherder.mozilla.org/#/jobs?repo=try&tier=1%2C2%2C3&revision=00fb2318d6ab625f0db81186255ea0687ac29f5e

Assignee: nobody → gbrown

Try artifact builds still don't build target.gtests.tar.gz; I think that's expected.

Pushed by gbrown@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b1571c522183
Include target.gtest.tests.tar.gz in android builds; r=bc

Sorry, I forgot that I need to land the first patch from bug 1318091 first.

Flags: needinfo?(gbrown)
Pushed by gbrown@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9eb55c9bf557
Include target.gtest.tests.tar.gz in android builds; r=bc
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
No longer depends on: 1543323
Regressions: 1543323
You need to log in before you can comment on or make changes to this bug.