Closed Bug 1532747 Opened 8 months ago Closed 6 months ago

Create raptor fenix and reference browser tasks that run on Try

Categories

(Testing :: Raptor, defect, P1)

Version 3
defect

Tracking

(firefox68 fixed)

RESOLVED FIXED
mozilla68
Tracking Status
firefox68 --- fixed

People

(Reporter: ahal, Assigned: ahal)

References

Details

Attachments

(2 files, 1 obsolete file)

The fenix team is going to be running raptor in their github-based CI. To do this they are going to pin a geckoview nightly build to use, and download the raptor from the same revision (using the taskcluster index + artifacts).

This is all well and fine, but sometimes they might update to a newer version of gecko+raptor and things will break, or there will be a performance regression. In this case, they might need to run a bisection, get help from a gecko developer, etc. Gecko developers won't want to setup Fenix just to help someone dig in.

This means that in addition to running raptor-fenix in the Fenix CI, we'll want to run raptor-fenix in the Gecko CI as well.

This will be try only at first, so it's probably fine to just use the latest version of Fenix without worrying about pinning it (though maybe a revision could be specified somehow). The same logic applies to the reference browser tasks.

Maybe eventually we'll want to backout mozilla-central changes that regress Fenix performance, at which point we'll likely need to make a toolchain/fetch task for it. But for now grabbing the latest is fine.

Rob, Dave, you guys are CC'ed as an fyi. I don't expect anything from you related to this (at least for now ;)).

Priority: -- → P1
Assignee: nobody → ahal
Status: NEW → ASSIGNED

These will run on android-hw against the latest reference browser nightly.
Since they are try-only, they can only be scheduled with |mach try fuzzy
--full|.

Pushed by ahalberstadt@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/486395fabe66
[ci] Create try-only raptor reference-browser tasks, r=jmaher,rwood
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Depends on: 1541957
Pushed by ahalberstadt@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/39e6ec535eb4
Use 'mach python' with repackage.sh script, CLOSED TREE, r=catlee
Attachment #9055984 - Attachment is obsolete: true
See Also: → 1543932
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
See Also: → 1545175
Blocks: 1545175
See Also: 1545175
Pushed by ahalberstadt@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1acac8b55cf7
Create try-only raptor tp6m-1 fenix task, r=rwood
Status: REOPENED → RESOLVED
Closed: 7 months ago6 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.