Unable to use Service Worker in Private Browsing Mode

RESOLVED DUPLICATE of bug 781982

Status

()

defect
RESOLVED DUPLICATE of bug 781982
4 months ago
4 months ago

People

(Reporter: kevin.cheung, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.119 Safari/537.36

Steps to reproduce:

  1. Open Private Browsing Mode in Firefox
  2. Open https://web.autocad.com
  3. Login
  4. Open a file

Actual results:

Can't open file because Service Workers are not accepted.

Expected results:

Is it possible to support Service Workers on Firefox?

I'm afraid that Service Worker registration uses storage which is currently disabled entirely in Private Browsing Mode. See note in https://developer.mozilla.org/en-US/docs/Web/API/Service_Worker_API/Using_Service_Workers. Even though it's about IDB, not storage in general, I'll tentatively dup this to bug 781982.

Status: UNCONFIRMED → RESOLVED
Closed: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 781982
Component: Untriaged → DOM: IndexedDB
Product: Firefox → Core
Version: 65 Branch → Trunk
You need to log in before you can comment on or make changes to this bug.