Remove browsermob-proxy mixin from marionette harness package

RESOLVED FIXED in Firefox 67

Status

enhancement
P1
normal
RESOLVED FIXED
a month ago
a month ago

People

(Reporter: whimboo, Assigned: whimboo)

Tracking

(Blocks 1 bug)

Version 3
mozilla67
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox67 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Nowadays the development of the browsermob-proxy Python package is done on Github:
https://github.com/AutomatedTester/browsermob-proxy-py

That means that we most likely can get rid of the very outdated in-tree version of it:

https://searchfox.org/mozilla-central/source/testing/marionette/harness/marionette_harness/runner/mixins/browsermob-proxy-py

To not cause regressions for external consumers I will remove it once the upcoming releases have been done via bug 1530794.

As it looks like nothing in tree actually uses it. So lets replace it with the PyPI package, which is also mirrored on our internal pypi index server.

Assignee: nobody → hskupin
Status: NEW → ASSIGNED
Priority: -- → P1
The development of the package has been moved to:
https://github.com/AutomatedTester/browsermob-proxy-py

The in-tree version is outdated, and no longer developed.
Comment on attachment 9049082 [details] [diff] [review]
[marionette] Remove outdated browsermob-proxy mixin from marionette harness package

I'm not able to upload the patch to phabricator, and also cannot directly request review anymore for normal patches. Andreas, can you please review?
Attachment #9049082 - Flags: feedback?(ato)

The development of the package has been moved to:
https://github.com/AutomatedTester/browsermob-proxy-py

The in-tree version is outdated, and no longer developed.

Attachment #9049082 - Attachment is obsolete: true
Attachment #9049082 - Flags: feedback?(ato)

Comment 6

a month ago
Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/975644295f21
[marionette] Remove outdated browsermob-proxy mixin from marionette harness package. r=ato

Comment 7

a month ago
bugherder
Status: ASSIGNED → RESOLVED
Last Resolved: a month ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Blocks: 1534702
You need to log in before you can comment on or make changes to this bug.