Closed Bug 1532948 Opened 9 months ago Closed 8 months ago

Clear cache alongside cookies and site data when network.cookie.lifetimePolicy is 2

Categories

(Toolkit :: Data Sanitization, defect, P3)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
mozilla68
Tracking Status
firefox65 --- wontfix
firefox66 --- wontfix
firefox67 --- wontfix
firefox68 --- verified
firefox69 --- verified

People

(Reporter: vlucaci, Assigned: baku)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Affected versions

  • 66.0b13-build1
  • 65.0.2
  • 67.0a1

Affected platforms

  • Windows 10x64
  • Windows 7x64
  • macOS 10.13
  • Ubuntu 16.04x64

Steps to reproduce

  1. Launch FF.
  2. Go to about:preferences#privacy.
  3. Go to Cookies and Site data.
  4. Select the Delete cookies and site data when Firefox is closed option.
  5. Reach multiple cookie rich websites such as cnn, bbc, reddit, etc.
  6. Close FF.
  7. Launch FF
  8. Return to about:preferences#privacy.

Expected result

  • The stored cookies and cache value displayed is decreased substantially.

Actual result

  • The stored cookies and cache value displayed is either the same, has decreased an insignificant amount or even increased after FF restart.

Regression range

  • will return with regression ASAP

Additional notes

  • FF is closed via the X button(normal user shutdown)
  • The list from Manage Data... is emptied completely, even though the disk size value is unchanged.

Screen cast of the issue

Blocks: 1532735
Component: DOM → Preferences
Product: Core → Firefox
Has Regression Range: --- → no

Hey johannh, it looks like the storage value here comes from SiteDataManager.jsm. Are we somehow skipping a step when attempting to clear site data storage on shutdown?

Flags: needinfo?(jhofmann)

Pretty sure that this is just cache not being cleared on shutdown, which I guess is expected behavior right now. Considering that it's been like this for a while and nobody has complained until now I'm inclined to leave it at that and WONTFIX/INVALID this bug. Baku, any thoughts?

Component: Preferences → Data Sanitization
Flags: needinfo?(jhofmann) → needinfo?(amarchesini)
Product: Firefox → Toolkit

I confirm that, for session only domains, we delete just cookies and DOM storages. Image and network caches are not deleted.

But SiteDataSettings deletes much more than this and the feature is called in a similar way: "Manage Cookies and Site Data" vs "Delete cookies and site data when Firefox is closed".

I prefer to be consistent with SiteDataSettings and remove all, where 'all' means:

    Ci.nsIClearDataService.CLEAR_ALL_CACHES |        
    Ci.nsIClearDataService.CLEAR_COOKIES |
    Ci.nsIClearDataService.CLEAR_DOM_STORAGES |
    Ci.nsIClearDataService.CLEAR_SECURITY_SETTINGS |                                                         
    Ci.nsIClearDataService.CLEAR_EME |
    Ci.nsIClearDataService.CLEAR_PLUGIN_DATA
Flags: needinfo?(amarchesini)

Ok, fair enough, we should probably include cache in that setting, then.

Priority: -- → P3
Summary: Cookies,data and cache disk size value from about:preferences#privacy is not updating accordingly after closing FF → Clear cache alongside cookies and site data when network.cookie.lifetimePolicy is 2
Assignee: nobody → amarchesini
Depends on: 1536387
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/eb89a2f2c59c
Sanitize principal on shutdown should behave like 'Manage cache and Site Data' cleanup, r=johannh
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68

I'm guessing this can ride the trains to 68.

Hello,

Confirming this issue as verified fixed on 68.0b6 (64-bit) 20190529145824 and 69.0a1 (20190602221035) with Win10x64, macOS 10.14 and Ubuntu 16.04x64.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.