Closed Bug 1532996 Opened 9 months ago Closed 9 months ago

Disable test262 Atomics tests in SIMULATOR_ARM64

Categories

(Core :: JavaScript Engine: JIT, defect, P2)

67 Branch
x86_64
Unspecified
defect

Tracking

()

RESOLVED FIXED
mozilla67
Tracking Status
firefox67 --- fixed

People

(Reporter: sstangl, Assigned: sstangl)

References

Details

Attachments

(1 file)

Ion got backed out again in Bug 1528869. The cause was the test "test262/built-ins/Atomics/wait/waiterlist-order-of-operations-is-fifo.js" which failed in the ARM64 Simulator on x86_64.

Unlike the other simulators, the ARM64 Simulator does not support simulating atomic operations. Although it will run simple atomics code, anything complicated that depends on those functions actually being atomic with memory barriers is extremely prone to failure.

Really, it is just invalid to test Atomics code in the simulator; it can only be tested properly on hardware.

I agree with that assessment.

Atomic tests are invalid in the ARM64 Simulator, because it lacks proper atomics emulation.

The above patch adds "skip-if: arm64-simulator" logic to every test262 test that requested the presence of both Atomics and SharedArrayBuffer. The change was made by script, so you don't have to worry about typos.

Pushed by sstangl@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/73a0388d6ecb
Disable test262 atomic tests if ARM64_SIMULATOR. r=jwalden
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.