[Automated review] reviewbot checked python style rules for files that are explicitly excluded in .flake8

RESOLVED FIXED in Firefox 67

Status

defect
P1
major
RESOLVED FIXED
4 months ago
4 months ago

People

(Reporter: froydnj, Assigned: ahal)

Tracking

unspecified
mozilla67

Firefox Tracking Flags

(firefox67 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

4 months ago

https://phabricator.services.mozilla.com/D22385

.flake8 excludes moz.configure files:

https://searchfox.org/mozilla-central/rev/fbb251448feb7276f9b1d0a88f9c0cb1cd144ce4/.flake8#58

Yet reviewbot is warning about flake8 errors in those files.

Assignee: nobody → bpostelnicu
Severity: normal → major
Priority: -- → P1
Duplicate of this bug: 1533690

This is not related with the automated review process, the fact that is posted by the bot is just a side effect of the way how ./mach lint works for flake8 with wildcards. I think that this issue has been added once we've taken away the exclusion from flake8 in bug 1367092, more precisely here.
Since most of the work has been performed by ahal reassigning accordingly.

Assignee: bpostelnicu → ahal
Assignee

Comment 3

4 months ago

Good catch, yes this is a regression from that bug. Flake8 ignores the exclude directive completely if you pass in a direct path (as opposed to a directory), and this is what the reviewbot does via mach lint --outgoing.

Assignee

Comment 4

4 months ago

Flake8 ignores the 'exclude' section of the .flake8.yml if you pass in a direct
path to a file. To get around this we have some custom logic to handle these
exclusions for us, but this custom logic didn't account for globs.

Comment 5

4 months ago
bugherder
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
You need to log in before you can comment on or make changes to this bug.