windows/aarch64 - browser/base/content/test/general/browser_contextmenu_input.js | menuitem context-inspect-a11y has an access key -

RESOLVED FIXED in Firefox 67

Status

()

defect
P5
normal
RESOLVED FIXED
3 months ago
3 months ago

People

(Reporter: intermittent-bug-filer, Assigned: egao)

Tracking

(Blocks 1 bug)

unspecified
Firefox 67
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox67 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

3 months ago
treeherder

#[markdown(off)]
Filed by: egao [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=231977413&repo=try

https://queue.taskcluster.net/v1/task/duC_tLI7Q12fq1PB42TBMA/runs/0/artifacts/public/logs/live_backing.log

Test: opt-mochitest-browser-chrome-6

Context:
21:57:39 INFO - Popup Shown
21:57:39 INFO - TEST-PASS | browser/base/content/test/general/browser_contextmenu_input.js | checking if popup is open -
21:57:39 INFO - TEST-PASS | browser/base/content/test/general/browser_contextmenu_input.js | child menuitem #59 has an ID -
21:57:39 INFO - TEST-PASS | browser/base/content/test/general/browser_contextmenu_input.js | menuitem context-undo has a label -
21:57:39 INFO - TEST-PASS | browser/base/content/test/general/browser_contextmenu_input.js | menuitem context-undo has an access key -
21:57:39 INFO - TEST-PASS | browser/base/content/test/general/browser_contextmenu_input.js | --- seperator id is context-sep-undo -
21:57:39 INFO - TEST-PASS | browser/base/content/test/general/browser_contextmenu_input.js | child menuitem #61 has an ID -
21:57:39 INFO - TEST-PASS | browser/base/content/test/general/browser_contextmenu_input.js | menuitem context-cut has a label -
21:57:39 INFO - TEST-PASS | browser/base/content/test/general/browser_contextmenu_input.js | menuitem context-cut has an access key -
21:57:39 INFO - TEST-PASS | browser/base/content/test/general/browser_contextmenu_input.js | child menuitem #62 has an ID -
21:57:39 INFO - TEST-PASS | browser/base/content/test/general/browser_contextmenu_input.js | menuitem context-copy has a label -
21:57:39 INFO - TEST-PASS | browser/base/content/test/general/browser_contextmenu_input.js | menuitem context-copy has an access key -
21:57:39 INFO - TEST-PASS | browser/base/content/test/general/browser_contextmenu_input.js | child menuitem #63 has an ID -
21:57:39 INFO - TEST-PASS | browser/base/content/test/general/browser_contextmenu_input.js | menuitem context-paste has a label -
21:57:39 INFO - TEST-PASS | browser/base/content/test/general/browser_contextmenu_input.js | menuitem context-paste has an access key -
21:57:39 INFO - TEST-PASS | browser/base/content/test/general/browser_contextmenu_input.js | child menuitem #64 has an ID -
21:57:39 INFO - TEST-PASS | browser/base/content/test/general/browser_contextmenu_input.js | menuitem context-delete has a label -
21:57:39 INFO - TEST-PASS | browser/base/content/test/general/browser_contextmenu_input.js | menuitem context-delete has an access key -
21:57:39 INFO - TEST-PASS | browser/base/content/test/general/browser_contextmenu_input.js | --- seperator id is context-sep-paste -
21:57:39 INFO - TEST-PASS | browser/base/content/test/general/browser_contextmenu_input.js | child menuitem #66 has an ID -
21:57:39 INFO - TEST-PASS | browser/base/content/test/general/browser_contextmenu_input.js | menuitem context-selectall has a label -
21:57:39 INFO - TEST-PASS | browser/base/content/test/general/browser_contextmenu_input.js | menuitem context-selectall has an access key -
21:57:39 INFO - TEST-PASS | browser/base/content/test/general/browser_contextmenu_input.js | --- seperator id is inspect-separator -
21:57:39 INFO - TEST-PASS | browser/base/content/test/general/browser_contextmenu_input.js | child menuitem #88 has an ID -
21:57:39 INFO - TEST-PASS | browser/base/content/test/general/browser_contextmenu_input.js | menuitem context-inspect has a label -
21:57:39 INFO - TEST-PASS | browser/base/content/test/general/browser_contextmenu_input.js | menuitem context-inspect has an access key -
21:57:39 INFO - TEST-PASS | browser/base/content/test/general/browser_contextmenu_input.js | child menuitem #89 has an ID -
21:57:39 INFO - TEST-PASS | browser/base/content/test/general/browser_contextmenu_input.js | menuitem context-inspect-a11y has a label -
21:57:39 INFO - Not taking screenshot here: see the one that was previously logged
21:57:39 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_contextmenu_input.js | menuitem context-inspect-a11y has an access key -
21:57:39 INFO - Stack trace:
21:57:39 INFO - chrome://mochikit/content/browser-test.js:test_ok:1304
21:57:39 INFO - chrome://mochitests/content/browser/browser/base/content/test/general/contextmenu_common.js:getVisibleMenuItems:76
21:57:39 INFO - chrome://mochitests/content/browser/browser/base/content/test/general/contextmenu_common.js:checkMenu:195
21:57:39 INFO - chrome://mochitests/content/browser/browser/base/content/test/general/contextmenu_common.js:checkContextMenu:141
21:57:39 INFO - chrome://mochitests/content/browser/browser/base/content/test/general/contextmenu_common.js:test_contextmenu:339
21:57:39 INFO - chrome://mochitests/content/browser/browser/base/content/test/general/browser_contextmenu_input.js:test_text_input_readonly:239
21:57:39 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1106
21:57:39 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1134
21:57:39 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:995
21:57:39 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:803

Assignee

Comment 1

3 months ago

My guess is that the odd state of a11y that windows10-aarch64 hardware has is interfering with this test.

I will disable this as part of 1533114.

Assignee

Updated

3 months ago
Keywords: regression
Assignee

Updated

3 months ago
Blocks: 1533114

Comment 4

3 months ago
Pushed by egao@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/529994cea769
disable browser_contextmenu_input.js test due to possible a11y issue r=jmaher

Comment 5

3 months ago
bugherder
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
Comment hidden (Intermittent Failures Robot)
You need to log in before you can comment on or make changes to this bug.