windows/aarch64 - browser/base/content/test/plugins/browser_enable_DRM_prompt.js | Notification should be visible -

RESOLVED FIXED in Firefox 67

Status

()

defect
P5
normal
RESOLVED FIXED
3 months ago
2 months ago

People

(Reporter: intermittent-bug-filer, Assigned: egao)

Tracking

(Blocks 1 bug)

unspecified
mozilla67
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox67 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

3 months ago
treeherder

#[markdown(off)]
Filed by: egao [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=231977413&repo=try

https://queue.taskcluster.net/v1/task/duC_tLI7Q12fq1PB42TBMA/runs/0/artifacts/public/logs/live_backing.log

Test: opt-mochitest-browser-chrome-6

Context:
22:00:40 INFO - TEST-START | browser/base/content/test/plugins/browser_enable_DRM_prompt.js
22:00:40 INFO - Not taking screenshot here: see the one that was previously logged
22:00:40 INFO - Buffered messages logged at 22:00:40
22:00:40 INFO - Entering test bound
22:00:40 INFO - TEST-PASS | browser/base/content/test/plugins/browser_enable_DRM_prompt.js | EME request should be denied because EME disabled. -
22:00:40 INFO - Buffered messages finished
22:00:40 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/plugins/browser_enable_DRM_prompt.js | Notification should be visible -
22:00:40 INFO - Stack trace:
22:00:40 INFO - chrome://mochikit/content/browser-test.js:test_ok:1304
22:00:40 INFO - chrome://mochitests/content/browser/browser/base/content/test/plugins/browser_enable_DRM_prompt.js:null:47
22:00:40 INFO - resource://testing-common/BrowserTestUtils.jsm:withNewTab:111
22:00:40 INFO - chrome://mochitests/content/browser/browser/base/content/test/plugins/browser_enable_DRM_prompt.js:null:10
22:00:40 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1106
22:00:40 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1134
22:00:40 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:995
22:00:40 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:803
22:00:40 INFO - Not taking screenshot here: see the one that was previously logged
22:00:40 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/plugins/browser_enable_DRM_prompt.js | Uncaught exception - at chrome://mochitests/content/browser/browser/base/content/test/plugins/browser_enable_DRM_prompt.js:48 - TypeError: notification is null
22:00:40 INFO - Stack trace:
22:00:40 INFO - @chrome://mochitests/content/browser/browser/base/content/test/plugins/browser_enable_DRM_prompt.js:48:5
22:00:40 INFO - async*withNewTab@resource://testing-common/BrowserTestUtils.jsm:111:24
22:00:40 INFO - async*@chrome://mochitests/content/browser/browser/base/content/test/plugins/browser_enable_DRM_prompt.js:10:26
22:00:40 INFO - Tester_execTest/<@chrome://mochikit/content/browser-test.js:1106:34
22:00:40 INFO - Tester_execTest@chrome://mochikit/content/browser-test.js:1134:12
22:00:40 INFO - nextTest/<@chrome://mochikit/content/browser-test.js:995:14
22:00:40 INFO - SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:803:59
22:00:40 INFO - Leaving test bound
22:00:40 INFO - Console message: navigator.requestMediaKeySystemAccess promise rejected 0x80530009 'EME has been preffed off'
22:00:40 INFO - GECKO(10072) | MEMORY STAT | vsize 5850MB | vsizeMaxContiguous 69635308MB | residentFast 268MB | heapAllocated 116MB
22:00:40 INFO - TEST-OK | browser/base/content/test/plugins/browser_enable_DRM_prompt.js | took 402ms
22:00:40 INFO - Not taking screenshot here: see the one that was previously logged
22:00:40 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/plugins/browser_enable_DRM_prompt.js | Found an unexpected tab at the end of test run: https://example.com/browser/browser/base/content/test/plugins/empty_file.html -

Assignee

Comment 1

3 months ago

I suspect this is due to the lack of EME support in windows10-aarch64 builds.

Disabling for now, and this bug could serve as the tracking bug to have this test re-enabled once EME is supported.

Keywords: regression

Comment 4

3 months ago
Pushed by egao@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ad487a66a9af
disable browser_enable_DRM_prompt.js test r=jmaher

Comment 5

3 months ago
bugherder
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Assignee: nobody → egao
Comment hidden (Intermittent Failures Robot)
You need to log in before you can comment on or make changes to this bug.