Unlabelled buttons in Privacy preferences for content blocking extra information buttons

VERIFIED FIXED in Firefox 67

Status

()

defect
P1
normal
VERIFIED FIXED
a month ago
a month ago

People

(Reporter: Jamie, Assigned: ewright)

Tracking

({access, regression})

unspecified
Firefox 67
Points:
---

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox65 wontfix, firefox66 wontfix, firefox67+ verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

a month ago

STR:

  1. Open Privacy preferences.
  2. Press control+shift+c to open the Dev Tools Inspector.
  3. In the search box, type "#strictArrow" and press enter.
  4. Right click the #strictArrow button node and select "Show Accessibility Properties".
  5. Look at the "name" property.
    • Expected: A useful name like "More information".
    • Actual: Nothing.
  6. Look at the "states" property.
    • Expected: The "collapsed" state should be present.
    • Actual: It isn't.

These arrow buttons were introduced in bug 1501985. A screen reader user cannot be sure what these buttons will do, since they are unlabelled and don't indicate that they can be expanded. This might mean screen reader users are never aware there is additional information and controls that can be accessed.

This can be solved by:

  1. Giving these arrow buttons an accessibility label; e.g. aria-label="More information".
  2. Indicating on the button whether the content is expanded or collapsed using aria-expanded. For example, this would default to aria-expanded="false" and then change to aria-expanded="true" when the button is activated.

This was reported to me on Twitter: https://mobile.twitter.com/DerekRiemer/status/1103402408451993601

Comment 1

a month ago

[Tracking Requested - why for this release]:
Inaccessible UI in important secondary UI bits.

66 is shipping in a few days, can't fix this in time, so marking that wontfix.

Erica, could you take a look? Thanks.

Blocks: 1501985
Flags: needinfo?(ewright)
Keywords: regression
Priority: -- → P1
(Assignee)

Comment 2

a month ago

Thank you! I'll add them.

Assignee: nobody → ewright
Flags: needinfo?(ewright)
(Assignee)

Updated

a month ago
Status: NEW → ASSIGNED
(Assignee)

Comment 3

a month ago

Add tooltiptext to create a name attribute in accessibility tools, add an expanded and collapsed state.

Comment 4

a month ago
bugherder
Status: ASSIGNED → RESOLVED
Last Resolved: a month ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67

Comment 6

a month ago

Verified as fixed on Firefox Nightly 67.0a1 (2019-03-14) on Windows 10 x 64 and Ubuntu 16.04 x64 and Mac OS X 10.14.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.