Closed Bug 1533202 Opened 2 years ago Closed 2 years ago

Object preview in workers should work for WeakMap/WeakSet

Categories

(DevTools :: Debugger, enhancement, P2)

enhancement

Tracking

(firefox68 fixed)

RESOLVED FIXED
Firefox 68
Tracking Status
firefox68 --- fixed

People

(Reporter: loganfsmyth, Assigned: bhackett1024)

References

Details

Attachments

(3 files)

In https://bugzilla.mozilla.org/show_bug.cgi?id=1522244 we fixed preview for Map and Set, but things are still broken for WeakMap and WeakSet.

Priority: -- → P3
Priority: P3 → P2

New test (well, the test from bug 1522244 that got backed out and never relanded, plus new weakmap/weakset logic).

Assignee: nobody → bhackett1024
Pushed by bhackett@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/5587eca8e117
Part 1 - Supply ChromeUtils in worker debugger global scope, r=baku.
https://hg.mozilla.org/integration/mozilla-inbound/rev/e83e6a6b4b03
Part 2 - Enumerate WeakMap/WeakSet entries in workers, r=loganfsmyth.
https://hg.mozilla.org/integration/mozilla-inbound/rev/0ad12e8fb98c
Part 3 - Add test for previewing in workers.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
Regressions: 1531612

There is a high frequency rate of devtools failures: https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&searchStr=linux%2Cx64%2Cdebug%2Cmochitests%2Ctest-linux64%2Fdebug-mochitest-devtools-chrome-e10s-10%2Cm%28dt10%29 all of them with the following failure: devtools/client/debugger/test/mochitest/browser_dbg-worker-scopes.js | Uncaught exception - [object Object]

e.g.: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=243362666&repo=mozilla-central&lineNumber=20654

[task 2019-04-29T18:07:37.697Z] 18:07:37 INFO - Waiting for state change: selected source
[task 2019-04-29T18:07:37.698Z] 18:07:37 INFO - Finished waiting for state change: selected source
[task 2019-04-29T18:07:37.699Z] 18:07:37 INFO - Buffered messages finished
[task 2019-04-29T18:07:37.699Z] 18:07:37 INFO - TEST-UNEXPECTED-FAIL | devtools/client/debugger/test/mochitest/browser_dbg-worker-scopes.js | Uncaught exception - [object Object]
[task 2019-04-29T18:07:37.700Z] 18:07:37 INFO - Leaving test bound
[task 2019-04-29T18:07:37.706Z] 18:07:37 INFO - Console message: [JavaScript Error: "remote browser crashed while on http://example.com/browser/devtools/client/debugger/test/mochitest/examples/doc-worker-scopes.html
[task 2019-04-29T18:07:37.707Z] 18:07:37 INFO - " {file: "chrome://mochikit/content/mochitest-e10s-utils.js" line: 8}]
[task 2019-04-29T18:07:37.707Z] 18:07:37 INFO - e10s_init/<@chrome://mochikit/content/mochitest-e10s-utils.js:8:8
[task 2019-04-29T18:07:37.708Z] 18:07:37 INFO - EventListener.handleEvente10s_init@chrome://mochikit/content/mochitest-e10s-utils.js:6:10
[task 2019-04-29T18:07:37.709Z] 18:07:37 INFO - testInit@chrome://mochikit/content/browser-test.js:105:5
[task 2019-04-29T18:07:37.709Z] 18:07:37 INFO - setTimeout handler
@chrome://mochikit/content/browser-test.js:23:1
[task 2019-04-29T18:07:37.710Z] 18:07:37 INFO - loadChromeScripts@jar:file:///tmp/tmpQ59T5J.mozrunner/extensions/mochikit@mozilla.org.xpi!/api.js:13:25
[task 2019-04-29T18:07:37.710Z] 18:07:37 INFO - loadMochitest@jar:file:///tmp/tmpQ59T5J.mozrunner/extensions/mochikit@mozilla.org.xpi!/api.js:112:3
[task 2019-04-29T18:07:37.710Z] 18:07:37 INFO - @tests/mochitest/runtests.py:1780:5
[task 2019-04-29T18:07:37.711Z] 18:07:37 INFO - @tests/mochitest/runtests.py:1781:8
[task 2019-04-29T18:07:37.712Z] 18:07:37 INFO - evaluate.sandbox/promise<@chrome://marionette/content/evaluate.js:128:10
[task 2019-04-29T18:07:37.712Z] 18:07:37 INFO - evaluate.sandbox@chrome://marionette/content/evaluate.js:106:17
[task 2019-04-29T18:07:37.713Z] 18:07:37 INFO - GeckoDriver.prototype.execute_@chrome://marionette/content/driver.js:1029:28
[task 2019-04-29T18:07:37.713Z] 18:07:37 INFO - async*GeckoDriver.prototype.executeScript@chrome://marionette/content/driver.js:911:29
[task 2019-04-29T18:07:37.714Z] 18:07:37 INFO - despatch@chrome://marionette/content/server.js:289:40
[task 2019-04-29T18:07:37.714Z] 18:07:37 INFO - execute@chrome://marionette/content/server.js:262:16
[task 2019-04-29T18:07:37.716Z] 18:07:37 INFO - onPacket/<@chrome://marionette/content/server.js:235:20
[task 2019-04-29T18:07:37.716Z] 18:07:37 INFO - onPacket@chrome://marionette/content/server.js:236:9
[task 2019-04-29T18:07:37.717Z] 18:07:37 INFO - _onJSONObjectReady/<@chrome://marionette/content/transport.js:492:20
[task 2019-04-29T18:07:37.717Z] 18:07:37 INFO -
[task 2019-04-29T18:07:37.717Z] 18:07:37 INFO - GECKO(1068) | [ACTION] MAP_SCOPES [done] - {}
[task 2019-04-29T18:07:37.718Z] 18:07:37 INFO - GECKO(1068) | [ACTION] EVALUATE_EXPRESSIONS - {"type":"EVALUATE_EXPRESSIONS","cx":{"navigateCounter":0,"thread":"server1.conn95.child1/workerTarget23/context1","isPaused":true,"pauseCounter":1},"inputs":[],"results":[]}
[task 2019-04-29T18:07:37.719Z] 18:07:37 INFO - Removing tab.
[task 2019-04-29T18:07:37.719Z] 18:07:37 INFO - Waiting for event: 'TabClose' on [object XULElement].
[task 2019-04-29T18:07:37.719Z] 18:07:37 INFO - Got event: 'TabClose' on [object XULElement].
[task 2019-04-29T18:07:37.741Z] 18:07:37 INFO - Tab removed and finished closing
[task 2019-04-29T18:07:37.950Z] 18:07:37 INFO - TEST-FAIL | devtools/client/debugger/test/mochitest/browser_dbg-worker-scopes.js | Assertion count 1 is greater than expected range 0-0 assertions. -
[task 2019-04-29T18:07:37.950Z] 18:07:37 INFO - GECKO(1068) | MEMORY STAT | vsize 3515MB | residentFast 465MB | heapAllocated 137MB
[task 2019-04-29T18:07:37.951Z] 18:07:37 INFO - TEST-OK | devtools/client/debugger/test/mochitest/browser_dbg-worker-scopes.js | took 13175ms

It looks like it has started failing with this revision: https://hg.mozilla.org/mozilla-central/rev/0ad12e8fb98c2c20a249cdd9bed5e032a71c500f

:bhackett is there any chance you could take a look at this? Thank you.

Flags: needinfo?(bhackett1024)

(In reply to Natalia Csoregi [:nataliaCs] from comment #6)

There is a high frequency rate of devtools failures: https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&searchStr=linux%2Cx64%2Cdebug%2Cmochitests%2Ctest-linux64%2Fdebug-mochitest-devtools-chrome-e10s-10%2Cm%28dt10%29 all of them with the following failure: devtools/client/debugger/test/mochitest/browser_dbg-worker-scopes.js | Uncaught exception - [object Object]

It looks like it has started failing with this revision: https://hg.mozilla.org/mozilla-central/rev/0ad12e8fb98c2c20a249cdd9bed5e032a71c500f

:bhackett is there any chance you could take a look at this? Thank you.

This looks like the same thing as bug 1456013. This new test seems to have exposed a problem in the browser and was just disabled on linux debug builds to reduce the failure rate.

Flags: needinfo?(bhackett1024)
You need to log in before you can comment on or make changes to this bug.