Closed Bug 1533265 Opened 6 months ago Closed 4 months ago

Wire up GeckoNetworkManager for offline status

Categories

(GeckoView :: General, enhancement, P2)

enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1540573

People

(Reporter: JanH, Unassigned)

Details

It is part of the geckoview package, and the relevant Gecko APIs already query the GeckoNetworkManager through GeckoAppShell, but we never actually start the network manager in GeckoView to make it actually operational - at the moment only Fennec itself does that when starting up in GeckoApplication.

James says the GeckoView-powered app can monitor offline status themselves (possibly with a network monitor A-C component). The app could then tell GeckoView to go offline (bug 1533271) instead of the GeckoNetworkManager telling GeckoView or the app we went offline.

Status: NEW → RESOLVED
Closed: 6 months ago
Priority: -- → P3
Resolution: --- → DUPLICATE
Summary: Wire up GeckoNetworkManager? → Wire up GeckoNetworkManager for offline status
Duplicate of bug: 1533271

Would that cover the Gecko Network Status API (bug 677166), which is more than just offline mode, too?

Flags: needinfo?(snorp)

(In reply to Jan Henning [:JanH] from comment #2)

Would that cover the Gecko Network Status API (bug 677166), which is more than just offline mode, too?

Ugh, I totally forgot about that. I guess maybe we do need to do that bit ourselves. We should still have some API to allow the app to take us offline, though. I'm elevating the priority of this a bit since it impacts web compat due to the DOM API being broken.

Flags: needinfo?(snorp)
Priority: P3 → P2
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Status: REOPENED → RESOLVED
Closed: 6 months ago4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1540573
You need to log in before you can comment on or make changes to this bug.