Intermittent timeouts running raptor-tp6m-google-restaurants-geckoview

RESOLVED FIXED in Firefox 68

Status

enhancement
P1
normal
RESOLVED FIXED
3 months ago
29 days ago

People

(Reporter: marauder, Assigned: Bebe)

Tracking

(Blocks 1 bug)

Version 3
mozilla68
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox68 fixed)

Details

Attachments

(1 attachment)

Reporter

Updated

3 months ago
Summary: Investigating tp6-m raptor tests for raptor-tp6m-google-restaurants-geckoview → Investigating tp6-m raptor test for raptor-tp6m-google-restaurants-geckoview
Reporter

Updated

3 months ago
Assignee: nobody → marian.raiciof
Reporter

Updated

3 months ago
Summary: Investigating tp6-m raptor test for raptor-tp6m-google-restaurants-geckoview → Intermittent timeouts running raptor-tp6m-google-restaurants-geckoview

:maruader, what is the latest status for this, thanks? If you're looking into this please set as P1.

Flags: needinfo?(marian.raiciof)
Priority: -- → P2
Reporter

Comment 2

2 months ago

:rwood, this is failing on the first page cycle for FCP. It is a permafail.
I added all the changes : addEventListener, run_at, remove ttfi, remove hero, increase page_timeout, increase fcp try outs.

Everytime it fails, in the adb logcat i can see the error [JavaScript Error: "NaN"]

"
03-27 17:31:04.782 12079 12096 I GeckoConsole: received message from https://www.google.com/search?q=restaurants+near+me
03-27 17:31:04.783 12079 12096 I GeckoConsole: result: fnbpaint 644
03-27 17:31:04.796 12079 12096 I GeckoConsole: received message from https://www.google.com/search?q=restaurants+near+me
03-27 17:31:04.797 12079 12096 I GeckoConsole: result: dcf 489
03-27 17:31:04.804 12079 12096 I GeckoConsole: received message from https://www.google.com/search?q=restaurants+near+me
03-27 17:31:04.805 12079 12096 I GeckoConsole: result: loadtime 509
03-27 17:31:30.429 12079 12096 E GeckoConsole: [JavaScript Error: "1553700690429 Telemetry::CoveragePing ERROR no endpoint base set" {file: "resource://gre/modules/Log.jsm" line: 679}]
03-27 17:31:30.429 12079 12096 E GeckoConsole: append@resource://gre/modules/Log.jsm:679:12
03-27 17:31:30.429 12079 12096 E GeckoConsole: log@resource://gre/modules/Log.jsm:360:16
03-27 17:31:30.429 12079 12096 E GeckoConsole: error@resource://gre/modules/Log.jsm:368:10
03-27 17:31:30.429 12079 12096 E GeckoConsole: startup@resource://gre/modules/CoveragePing.jsm:40:11
03-27 17:31:30.429 12079 12096 E GeckoConsole: setupTelemetry/this._delayedInitTask<@resource://gre/modules/TelemetryController.jsm:719:30
03-27 17:31:30.446 12079 12096 E GeckoConsole: [JavaScript Error: "Polling for changes failed: NetworkError when attempting to fetch resource.." {file: "resource://services-settings/remote-settings.js" line: 199}]
03-27 17:31:30.446 12079 12096 E GeckoConsole: remoteSettingsFunction/remoteSettings.pollChanges@resource://services-settings/remote-settings.js:199:13
03-27 17:32:42.969 12079 12096 E GeckoConsole: [JavaScript Error: "NaN"]
03-27 17:32:42.971 12079 12096 I GeckoConsole: posting to control server
03-27 17:32:42.972 12079 12096 I GeckoConsole: raptor-tp6m-google-restaurants-geckoview,https://www.google.com/search?q=restaurants+near+me,[object Object]
03-27 17:32:42.980 12079 12096 I GeckoConsole: closed tab 0
03-27 17:32:42.982 12079 12096 I GeckoConsole: pageloader test finished
03-27 17:32:42.983 12079 12096 I GeckoConsole:
03-27 17:32:42.983 12079 12096 I GeckoConsole: __raptor_shutdownBrowser
"

On the other hand, the subtest "raptor-tp6m-google-maps-geckoview" from the same suite, is passing.

Flags: needinfo?(marian.raiciof)
Reporter

Updated

2 months ago
Priority: P2 → P1
Assignee

Updated

a month ago
Depends on: 1544781
Assignee

Comment 4

a month ago

The try build looks OK I will make a patch

Flags: needinfo?(fstrugariu)
Assignee

Updated

a month ago
Assignee: marian.raiciof → fstrugariu
Flags: needinfo?(fstrugariu)

Comment 7

a month ago
Pushed by fstrugariu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e7dc7b90caad
Intermittent timeouts running raptor-tp6m-google-restaurants-geckoview r=AlexandruIonescu

Comment 8

a month ago
bugherder
Status: NEW → RESOLVED
Last Resolved: a month ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Duplicate of this bug: 1541431
You need to log in before you can comment on or make changes to this bug.