Closed Bug 1533287 Opened 6 months ago Closed 2 months ago

Intermittent timeouts running raptor-tp6m-cnn-geckoview

Categories

(Testing :: Raptor, enhancement, P2)

Version 3
enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1564046

People

(Reporter: marauder, Assigned: marauder)

References

Details

Assignee: nobody → marian.raiciof
Summary: Investigating tp6-m raptor test for raptor-tp6m-cnn-geckoview → Intermittent timeouts running raptor-tp6m-cnn-geckoview

:marauder, what is the status of this? Thanks!

Flags: needinfo?(marian.raiciof)
Priority: -- → P2

This test still fails on local environment.
Anyway, i removed the disabled attribute and did a push to try :
https://treeherder.mozilla.org/#/jobs?repo=try&revision=5f188ffff313ce52a24ff2df7a9859550ed10aab

Flags: needinfo?(marian.raiciof)

I retriggered the jobs, and saw 2 failures out of 20 builds. In both cases all metrics were still pending. Marian: could you push to try with screenshots enabled so we can see the state of the browser at the point of the timeout. We should keep this under investigation.

Hi Dave,

This is the new push to try with screenshots enabled:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=77e657e563d4d70ba2478ce18157052d9f5ec78d

Depends on: 1550455

Do we have any new updates?

Flags: needinfo?(dave.hunt)

We still have many tests that are failing intermittently due to timeouts. There are no new updates for this specific site that I am aware of. Do we need to raise the priority of this?

Flags: needinfo?(dave.hunt) → needinfo?(vchin)

What is the cause of the timeouts? Are we seeing timeouts on both cold and warm loads?

Flags: needinfo?(vchin)

(In reply to Vicky Chin [:vchin] from comment #8)

What is the cause of the timeouts? Are we seeing timeouts on both cold and warm loads?

This isn't something we've been able to determine yet. It's possibly a race condition somewhere, perhaps in the Raptor web extension. There have always been intermittent page load timeouts, and the acceleration of the number of sites we test and the number of browsers we're running them against over the last 6 months has not helped. The timeouts occur on both cold and warm page loads. We're currently focusing on driving down these intermittents, and developing new strategies to help us to investigate, resolve, and be more resiliant to these flaky tests.

:marauder could you revisit this with the recent fixes, to see if it's more stable now?

Flags: needinfo?(marian.raiciof)
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1564046
You need to log in before you can comment on or make changes to this bug.