History not imported from IE and therefore IE passwords are not imported on Windows 7

VERIFIED FIXED in Firefox 67

Status

()

defect
P1
normal
VERIFIED FIXED
3 months ago
2 months ago

People

(Reporter: danibodea, Assigned: MattN)

Tracking

(Depends on 1 bug, {regression})

Trunk
Firefox 67
Desktop
Windows 7
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox65 wontfix, firefox66+ wontfix, firefox67+ verified)

Details

Attachments

(3 attachments)

Reporter

Description

3 months ago

Note

  • This bug has been logged as a request from bug 1520949 and it is blocking bug 682069.
  • When a Windows 7 user migrates from IE11 to Firefox and attempts to import the data from the other browser, he will notice that the passwords, history and other data will not be imported.

Affected versions

  • Nightly v67.0a1 from 2019-03-05
  • Beta v66.0b14
  • Release v65.0.2

Affected platforms

  • Windows 7 ONLY

Steps to reproduce

  1. Firstly, I have saved the passwords into IE11 using the auto-save feature ("User names and passwords on forms" is CHECKED and "Ask me before saving passwords" is CHECKED, settings found in IE11 at Internet Options, Content tab, Auto-Complete Settings button), logged into some websites and chose to save the credentials in the automatic pop-up.
  2. I have confirmed that the passwords were saved by logging out and reloading the page to see whether the credentials were actually saved, then again after a browser restart.
  3. I have attempted to import the credentials into Firefox using Firefox's import feature.

Expected result

  • The passwords and history saved into IE should be correctly imported into Firefox.

Actual result

  • No password, history or other data were imported from IE11 into Firefox.
  • Error displayed in Browser Console: "We failed to decrypt and import some logins. This is likely because we didn't find the URLs where these passwords were submitted in the IE history and which are needed to be used as keys in the decryption."
Reporter

Comment 1

3 months ago

I have performed a mozregression to find the regressor and these are the last console messages:
"2019-03-07T10:04:10: INFO : Narrowed inbound regression window from [e3bbdb2f, 2bd127de] (3 builds) to [b88f5fa7, 2bd127de] (2 builds) (~1 steps left)
2019-03-07T10:04:10: DEBUG : Starting merge handling...
2019-03-07T10:04:10: DEBUG : Using url: https://hg.mozilla.org/integration/mozilla-inbound/json-pushes?changeset=2bd127de1f05cd8379c279caea727690b847e5b9&full=1
2019-03-07T10:04:21: DEBUG : Found commit message:
Bug 1484496: Part 6 - Remove unused XPCOMUtils.IterSimpleEnumerator method. r=mccr8

Differential Revision: https://phabricator.services.mozilla.com/D3734

2019-03-07T10:04:21: DEBUG : Did not find a branch, checking all integration branches
2019-03-07T10:04:21: INFO : The bisection is done.
2019-03-07T10:04:21: INFO : Stopped"

Blocks: 1484496
Keywords: regression
Priority: -- → P1
Flags: needinfo?(kmaglione+bmo)

I think the problem is that that enumerator expects you to call hasMoreElements() before getNext(), but the iterator protocol doesn't require that, so the JS iterator stubs don't do it.

Flags: needinfo?(kmaglione+bmo)

(In reply to Bodea Daniel [:danibodea] from comment #0)

Affected platforms

  • Windows 7 ONLY

Are you sure? This should affect history import from IE on all Windows versions.

It should only affect password import on Windows 7 since it changed from Windows 8+ (independent of IE version).

Assignee: nobody → MattN+bmo
Status: NEW → ASSIGNED
Flags: qe-verify+
Flags: needinfo?(daniel.bodea)
Flags: in-testsuite?
Summary: Passwords, History and others are not imported from IE11 on Windows 7 → History not imported from IE and therefore IE passwords are not imported on Windows 7
Reporter

Comment 9

2 months ago

(In reply to Matthew N. [:MattN] (PM me if requests are blocking you) from comment #4)

(In reply to Bodea Daniel [:danibodea] from comment #0)

Affected platforms

  • Windows 7 ONLY

Are you sure? This should affect history import from IE on all Windows versions.

It should only affect password import on Windows 7 since it changed from Windows 8+ (independent of IE version).

You are right, Matthew. The history is not imported in Windows 10 either, from IE11 to Nightly v67.0a1 from 2019-03-10.
Sorry for the confusion, initially I have only checked for the password import that was the main issue, which does import as expected. I have to mention that I haven't checked the Windows 8 behavior due to the time pressure and OS unpopularity.

Flags: needinfo?(daniel.bodea)
Attachment #9049728 - Attachment description: Bug 1533288 - Add an executable to insert IE history on test machines. r=jaws → Bug 1533288 - Add an executable to insert IE history on test machines. r=jaws,mshal

Comment 10

2 months ago
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/autoland/rev/5a255779e2a7
Don't assume HasMoreElements() is called before GetNext() in nsIEHistoryEnumerator. r=jaws
https://hg.mozilla.org/integration/autoland/rev/7651c91b361b
Add an executable to insert IE history on test machines. r=jaws,firefox-build-system-reviewers,mshal
https://hg.mozilla.org/integration/autoland/rev/53ab271d6020
Test import of Internet Explorer history. r=jaws

Comment 11

2 months ago
bugherder
Status: ASSIGNED → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67

Comment 12

2 months ago

Verified the issue on Windows 7 x64 and Windows 10 x64 on latest Nightly 67.0a1 (buildID: 20190313215409)

  • Windows 10 x64: both history and bookmarks are imported from Edge
  • Windows 7 x64: Only history is imported from Internet Explorer, the passwords are missing. Browser console shows this error: https://imgur.com/a/iLzA668

Hey Matt, please take a look at this when you have the time. Thanks

Flags: needinfo?(MattN+bmo)

(In reply to Timea Babos from comment #12)

Verified the issue on Windows 7 x64 and Windows 10 x64 on latest Nightly 67.0a1 (buildID: 20190313215409)

  • Windows 10 x64: both history and bookmarks are imported from Edge
  • Windows 7 x64: Only history is imported from Internet Explorer, the passwords are missing. Browser console shows this error: https://imgur.com/a/iLzA668

Hey Matt, please take a look at this when you have the time. Thanks

Thank you, I have filed bug 1535757 for the existing password issue. Looks like History import is fixed.

Flags: needinfo?(MattN+bmo)

Comment 14

2 months ago

Thanks Matt! Marking this as verified for Firefox 67.

Flags: in-testsuite? → in-testsuite+

Updated

2 months ago
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.