The applications list in Preferences leaves the top entry (and duplicates it) when filtering/sorting

VERIFIED FIXED in Firefox 66

Status

()

defect
P1
normal
VERIFIED FIXED
4 months ago
4 months ago

People

(Reporter: csasca, Assigned: Gijs)

Tracking

(Blocks 1 bug, {regression})

Trunk
Firefox 67
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox65 unaffected, firefox66 verified, firefox67 verified)

Details

Attachments

(2 attachments)

Reporter

Description

4 months ago

Affected versions

  • Firefox Beta 66.0b13
  • Firefox Nightly 67.0a1

Affected platforms

  • Windows 10 (x64
  • macOS 10.12
  • Ubuntu 18.04 (x64)

Steps to reproduce

  1. Start Firefox
  2. Go to about:preferences and scroll down to Applications
  3. Select one application (eg. webcal or irc) and then click on Content Type

Expected result

  • The applications are sorted out without issues.

Actual result

  • The selection is duplicated in the list.

Regression range
I will come back with a regression asap.

Additional notes

  • The issue is not reproducible on Firefox 65.0.2.
Reporter

Updated

4 months ago
Has Regression Range: --- → no
Has STR: --- → yes
Reporter

Comment 1

4 months ago
Posted image Duplicate.gif

Here's a screencast for the issue.

Marking as regression since comment 0 says it's not reproducible in Firefox 65.0.2.

Flagging needinfo for the regression range.

Flags: needinfo?(catalin.sasca)
Keywords: regression
Assignee

Comment 4

4 months ago

I bet there's sorting code here that assumes that the first child is the header and ignores it, and when bug 1516442 moved the headers out, it didn't touch that code.

Makes me wonder if other sortable lists are also affected.

Flags: needinfo?(catalin.sasca)
Assignee

Updated

4 months ago
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Assignee

Updated

4 months ago
Summary: Selection from Applications in Preferences are duplicated after sorting them out → The applications list in Preferences leaves the top entry (and duplicates it) when filtering/sorting
Priority: -- → P1
Assignee

Updated

4 months ago
Depends on: 1533477

Comment 7

4 months ago
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/109c5ab8dd9a
stop leaving an item in the application handler list when sorting/filtering, r=jaws

Comment 8

4 months ago
bugherder
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
Assignee

Comment 9

4 months ago

Comment on attachment 9049249 [details]
Bug 1533389 - stop leaving an item in the application handler list when sorting/filtering, r?jaws

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: Bug 1516442
  • User impact if declined: a duplicate/mismatching item appears at the top of the application/handler list in the preferences when sorting or filtering it
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: See comment #0
  • List of other uplifts needed: n/a
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The patch in itself is very straightforward (-2/+1 lines of JS), any risk is coming from the fact that we're out of beta runway, and the lack of automated testing here (there are tests, but they're clearly not exercising this code to the point where they noticed the issue...)
  • String changes made/needed: None
Attachment #9049249 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9049249 [details]
Bug 1533389 - stop leaving an item in the application handler list when sorting/filtering, r?jaws

Seems straightforward; in this case I'm ok with uplifting now for the RC and verifying afterwards.

Attachment #9049249 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment 12

4 months ago

Hi Gijs, we're porting this to TB in bug 1533650. To me the "obvious" solution would have been to change > 1 to >= 1. So this._list.textContent = ""; is the quicker and better way? Is there other code that clears lists the "traditional" way?

Flags: needinfo?(gijskruitbosch+bugs)
Assignee

Comment 13

4 months ago

(In reply to Jorg K (GMT+1) from comment #12)

Hi Gijs, we're porting this to TB in bug 1533650. To me the "obvious" solution would have been to change > 1 to >= 1. So this._list.textContent = ""; is the quicker and better way?

It's slightly faster, and shorter to write.

Is there other code that clears lists the "traditional" way?

Probably, but I wanted to fix this bug, not change lots of old, working code.

Flags: needinfo?(gijskruitbosch+bugs)
QA Whiteboard: [qa-triaged]
Has Regression Range: no → yes
Reporter

Comment 14

4 months ago

The issue is no longer reproducible on Firefox 66.0b15 build from treeherder (20190310020310) and latest Nightly 67.0a1 (2019-03-11). Tests were performed under Windows 10 (x64), Ubuntu 18.04 (x64) and macOS 10.12.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.