Closed Bug 1533394 Opened 9 months ago Closed 8 months ago

Intermittent netwerk/cookie/test/browser/browser_serviceWorker.js | A promise chain failed to handle a rejection: [Exception... "Abort" nsresult: "0x80004004 (NS_ERROR_ABORT)" location: "<unknown>" data: no] - stack: (No stack available.)

Categories

(Core :: Networking: Cookies, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- unaffected
firefox67 --- fixed
firefox68 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: ehsan)

References

Details

(Keywords: intermittent-failure, regression, Whiteboard: [necko-triaged][stockwell fixed])

Attachments

(2 files)

#[markdown(off)]
Filed by: aciure [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=232412858&repo=autoland

https://queue.taskcluster.net/v1/task/dtanHrpTRGOY6CrlUtvhyQ/runs/0/artifacts/public/logs/live_backing.log

13:34:17 INFO - TEST-PASS | netwerk/cookie/test/browser/browser_serviceWorker.js | ServiceWorker can be used! - true == true -
13:34:17 INFO - Console message: [JavaScript Error: "NS_ERROR_ABORT"]
13:34:17 INFO - Console message: [JavaScript Error: "NS_ERROR_ABORT"]
13:34:17 INFO - Console message: [JavaScript Error: "NS_ERROR_ABORT"]
13:34:17 INFO - Console message: [JavaScript Error: "NS_ERROR_ABORT"]
13:34:17 INFO - Console message: [JavaScript Error: "NS_ERROR_ABORT"]
13:34:17 INFO - Console message: [JavaScript Error: "NS_ERROR_ABORT"]
13:34:17 INFO - Console message: [JavaScript Error: "NS_ERROR_ABORT"]
13:34:17 INFO - Console message: [JavaScript Error: "NS_ERROR_ABORT"]
13:34:17 INFO - Buffered messages finished
13:34:17 INFO - TEST-UNEXPECTED-FAIL | netwerk/cookie/test/browser/browser_serviceWorker.js | A promise chain failed to handle a rejection: [Exception... "Abort" nsresult: "0x80004004 (NS_ERROR_ABORT)" location: "<unknown>" data: no] - stack: (No stack available.)
13:34:17 INFO - Rejection date: Thu Mar 07 2019 05:34:17 GMT-0800 (Pacific Standard Time) - false == true - JS frame :: resource://testing-common/PromiseTestUtils.jsm :: assertNoUncaughtRejections :: line 257
13:34:17 INFO - Stack trace:
13:34:17 INFO - resource://testing-common/PromiseTestUtils.jsm:assertNoUncaughtRejections:257
13:34:17 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1130
13:34:17 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1134
13:34:17 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:995
13:34:17 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:803
13:34:17 INFO - Leaving test bound
13:34:17 INFO - GECKO(1184) | MEMORY STAT | vsize 4429MB | residentFast 355MB | heapAllocated 138MB
13:34:17 INFO - TEST-OK | netwerk/cookie/test/browser/browser_serviceWorker.js | took 1881ms
13:34:17 INFO - checking window state

This seems to be coming from Bug 1525245, Andrea can you take a look?

Flags: needinfo?(amarchesini)
Whiteboard: [stockwell disable-recommended] → [stockwell needswork:owner]
Whiteboard: [stockwell disable-recommended] → [stockwell disabled]
Pushed by ccoroiu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/634792168a9d
Disable browser_serviceWorker.js on Linux, Mac and Windows 7. r=aryx

Andrew is going to take a look as discussed on IRC.

Flags: needinfo?(amarchesini) → needinfo?(bugmail)

The fix on bug 1498102 should fix this bug. (Analysis happened in https://bugzilla.mozilla.org/show_bug.cgi?id=1498102#c54 with :ehsan providing a fix.)

Depends on: 1498102
Flags: needinfo?(bugmail)
Assignee: nobody → ehsan
Keywords: leave-open
Priority: -- → P3
Whiteboard: [stockwell disabled] → [necko-triaged][stockwell disabled]
Pushed by eakhgari@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d3a1f902e1e2
Re-enable browser_serviceWorker.js now that bug 1498102 has been fixed; r=asuth
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Flags: in-testsuite+
Whiteboard: [necko-triaged][stockwell disabled] → [necko-triaged][stockwell fixed]
You need to log in before you can comment on or make changes to this bug.