Closed Bug 1533429 Opened 1 year ago Closed 1 year ago

atk_text_get_caret_offset should return -1 when the caret is outside the element and for failure

Categories

(Core :: Disability Access APIs, defect, P2)

Desktop
Linux
defect

Tracking

()

RESOLVED FIXED
mozilla67
Tracking Status
firefox67 --- fixed

People

(Reporter: mrobinson, Assigned: mrobinson)

Details

Attachments

(1 file)

See the discussion here: https://gitlab.gnome.org/GNOME/atk/merge_requests/14#note_453109

In order to distinguish between a caret that is outside the element or a failure to get the caret position and a caret that is at offset=0, atk_text_get_caret_offset should return -1 in the former cases.

This makes Gecko conform to the newly documented expected behavior of ATK.

MozReview-Commit-ID: K9sRUDqeLq4

Assignee: nobody → mrobinson
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

I no longer have try access, so this probably needs a try push as well.

(In reply to Martin Robinson (email:mrobinson@igalia.com) from comment #2)

I no longer have try access, so this probably needs a try push as well.

if it builds, then try run won't catch anything, because atk part have zero test coverage. Do you confirm it works as expected? If so, then I think we can proceed and land it as is.

Pushed by cbrindusan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/de071244b632
Return -1 for atk_text_get_caret_offset when we can't get the offset r=surkov

Keywords: checkin-needed
Priority: -- → P2
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
You need to log in before you can comment on or make changes to this bug.