Intermittent TV dom/ipc/tests/browser_JSWindowActor.js | Should throw if includeChrome is false. -

RESOLVED FIXED in Firefox 68

Status

()

defect
P1
normal
RESOLVED FIXED
6 months ago
4 months ago

People

(Reporter: intermittent-bug-filer, Assigned: Nika)

Tracking

({intermittent-failure, regression})

unspecified
mozilla68
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Fission Milestone:M2, firefox-esr60 unaffected, firefox66 unaffected, firefox67 unaffected, firefox68 fixed)

Details

(Whiteboard: [stockwell unknown])

Attachments

(1 attachment)

#[markdown(off)]
Filed by: aciure [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=232469435&repo=autoland

https://queue.taskcluster.net/v1/task/Dlg3gVHLQdOstm9DnmzWow/runs/0/artifacts/public/logs/live_backing.log

[task 2019-03-07T17:43:19.848Z] 17:43:19 INFO - TEST-PASS | dom/ipc/tests/browser_JSWindowActor.js | JSWindowActorChild should have value. - {} == true -
[task 2019-03-07T17:43:19.850Z] 17:43:19 INFO - Leaving test bound test_getActor_with_allFrames
[task 2019-03-07T17:43:19.853Z] 17:43:19 INFO - Entering test bound test_getActor_without_includeChrome
[task 2019-03-07T17:43:19.854Z] 17:43:19 INFO - Buffered messages finished
[task 2019-03-07T17:43:19.855Z] 17:43:19 INFO - TEST-UNEXPECTED-FAIL | dom/ipc/tests/browser_JSWindowActor.js | Should throw if includeChrome is false. -
[task 2019-03-07T17:43:19.856Z] 17:43:19 INFO - Stack trace:
[task 2019-03-07T17:43:19.857Z] 17:43:19 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.ok:275
[task 2019-03-07T17:43:19.857Z] 17:43:19 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.doesThrow:343
[task 2019-03-07T17:43:19.859Z] 17:43:19 INFO - chrome://mochitests/content/browser/dom/ipc/tests/browser_JSWindowActor.js:test_getActor_without_includeChrome:97
[task 2019-03-07T17:43:19.859Z] 17:43:19 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1106
[task 2019-03-07T17:43:19.860Z] 17:43:19 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1134
[task 2019-03-07T17:43:19.861Z] 17:43:19 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:990
[task 2019-03-07T17:43:19.862Z] 17:43:19 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:803
[task 2019-03-07T17:43:19.865Z] 17:43:19 INFO - Leaving test bound test_getActor_without_includeChrome
[task 2019-03-07T17:43:19.866Z] 17:43:19 INFO - Entering test bound test_getActor_with_includeChrome
[task 2019-03-07T17:43:19.867Z] 17:43:19 INFO - TEST-PASS | dom/ipc/tests/browser_JSWindowActor.js | JSWindowActorParent should have value. -

There have been 33 failures within the last 7 days:

  • 5 failures on Linux x64 debug/pgo
  • 2 failures on Linux x64 shippable opt
  • 5 failures on OS X 10.10 debug/opt
  • 3 failures on OS X 10.10 shippable opt
  • 6 failures on Windows 10 x64 debug/opt/pgo
  • 3 failures on Windows 10 x64 Shippable opt
  • 6 failures on Windows 7 debug/opt/pgo
  • 3 failures on Windows 7 Shippable opt

Recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=236578187&repo=mozilla-inbound&lineNumber=11991

[task 2019-03-28T11:23:52.035Z] 11:23:52 INFO - TEST-PASS | dom/ipc/tests/browser_JSWindowActor.js | JSWindowActorChild should have value. - {} == true -
[task 2019-03-28T11:23:52.035Z] 11:23:52 INFO - Leaving test bound test_getActor_with_allFrames
[task 2019-03-28T11:23:52.035Z] 11:23:52 INFO - Entering test bound test_getActor_without_includeChrome
[task 2019-03-28T11:23:52.035Z] 11:23:52 INFO - Buffered messages finished
[task 2019-03-28T11:23:52.044Z] 11:23:52 INFO - TEST-UNEXPECTED-FAIL | dom/ipc/tests/browser_JSWindowActor.js | Should throw if includeChrome is false. -
[task 2019-03-28T11:23:52.049Z] 11:23:52 INFO - Stack trace:
[task 2019-03-28T11:23:52.049Z] 11:23:52 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.ok:275
[task 2019-03-28T11:23:52.050Z] 11:23:52 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.doesThrow:343
[task 2019-03-28T11:23:52.052Z] 11:23:52 INFO - chrome://mochitests/content/browser/dom/ipc/tests/browser_JSWindowActor.js:test_getActor_without_includeChrome:384
[task 2019-03-28T11:23:52.053Z] 11:23:52 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1106
[task 2019-03-28T11:23:52.054Z] 11:23:52 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1134
[task 2019-03-28T11:23:52.055Z] 11:23:52 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:990
[task 2019-03-28T11:23:52.061Z] 11:23:52 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:803
[task 2019-03-28T11:23:52.062Z] 11:23:52 INFO - Leaving test bound test_getActor_without_includeChrome
[task 2019-03-28T11:23:52.063Z] 11:23:52 INFO - Entering test bound test_getActor_with_includeChrome
[task 2019-03-28T11:23:52.070Z] 11:23:52 INFO - TEST-PASS | dom/ipc/tests/browser_JSWindowActor.js | JSWindowActorParent should have value. -

Flags: needinfo?(jmathies)
Whiteboard: [stockwell needswork:owner]
Summary: Intermittent dom/ipc/tests/browser_JSWindowActor.js | Should throw if includeChrome is false. - → Intermittent TV dom/ipc/tests/browser_JSWindowActor.js | Should throw if includeChrome is false. -

moving this to ipc for triage.

Component: DOM: Content Processes → IPC
Flags: needinfo?(jmathies)
Priority: P5 → --

This is caused by the tests re-using the same global in some cases when they shouldn't be. I'll take this as it should be a pretty quick fix.

Assignee: nobody → nika
Blocks: 1467212
Priority: -- → P1
Fission Milestone: --- → M2

Nika can we add this t the checkin-needed queue?

Flags: needinfo?(nika)
Flags: needinfo?(nika)

updated & queued for landing with lando

Pushed by nlayzell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d29ba08c6cd9
Use a new window for each JSWindowActor test, r=jdai
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Regressions: 1546806
You need to log in before you can comment on or make changes to this bug.