Closed Bug 1533483 Opened 5 years ago Closed 5 years ago

"transform" CSS property isn't supported in <marker>

Categories

(Core :: SVG, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1323962
Tracking Status
firefox67 --- affected

People

(Reporter: dholbert, Unassigned)

Details

Attachments

(1 file)

STR:

  1. Load attached testcase.

EXPECTED RESULTS:
You should see three diamonds (three 45-degree-rotated rects)

ACTUAL RESULTS:
The lowest rect (teal) is not rotated at all. It just looks like a square.

Chrome 74, Safari 12, and Edge 18 all give EXPECTED RESULTS.
Firefox Nightly 67 gives ACTUAL RESULTS.

The problematic rect is rendered via marker and is rotated using the transform CSS property. The other two rects are exercising each of these features on their own, and they work correctly in isolation. (The top rect is just a normal rect -- no marker -- and is rotated using the transform CSS property. And the middle rect is inside of a marker and is rotated using the transform attribute which works correctly. Only the 3rd one, the marker with the transform property, has trouble.)

Attached file testcase 1

This is kind of similar to bug 1323962. markers are non-display and we don't support CSS transforms on any non-display elements because we don't render them with display lists.

Thanks. Sounds like this is basically a dupe of that more general issue -- I'll mark it as such (and adjust the other bug's summary to mention marker).

Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.