Composition window is completely broken.

VERIFIED FIXED

Status

MailNews Core
Composition
--
blocker
VERIFIED FIXED
16 years ago
9 years ago

People

(Reporter: Frederic Bezies, Assigned: Jean-Francois Ducarroz)

Tracking

({regression, smoketest})

Trunk
x86
All
regression, smoketest

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1a+) Gecko/20020620
BuildID:    20020621

In the first round of Mozilla build for 21 june 2002, composition window is
completely broken.

Reproducible: Always
Steps to Reproduce:
1.Select a mail
2.Try to reply it :-/


Actual Results:  No from. No quoted text. Composition windows like in HTML
compose mode, even if text mode is selected for account. And From  line shows
"..." instead of good header.

Expected Results:  A working compose window

I saw it on trunk build 20020621-04 (??) under WinXP and after chatting on IRC,
it was confirmed by Cartman compiling CVS sources.

Comment 1

16 years ago
Confirming on LinuX Mozilla Build 2002062115
(Assignee)

Comment 2

16 years ago
I am pulling a tree to see the problem...
Status: NEW → ASSIGNED
Keywords: smoketest

Comment 3

16 years ago
i'm also seeing this with this mornings commercial trunk builds on:
windows98 2002-06-21-04-trunk
linux 2002-06-21-04-trunk
Keywords: regression
(Assignee)

Comment 4

16 years ago
I am still building but looking at the checkins, I found that timeless
introduced a syntax error during his checkin in nsMsgComposeCommands.js

Comment 5

16 years ago
indeed bug 143515, note that the file's name is MsgComposeCommands.js
to use cvs guess, you need to spell the file's name correctly...
http://bonsai.mozilla.org/cvsguess.cgi?file=MsgComposeCommands.js

i'll gladly fix this, if a sheriff or build engineer or someone signs off. the 
patch was checked in exactly as attached.
(Assignee)

Comment 6

16 years ago
Fix checked in the trunk. Please pull nsMsgComposeCommands.js and rebuild the
mailnews chrome.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

16 years ago
right, it's MsgComposeCommands.js
(Reporter)

Comment 8

16 years ago
Bug is dead ! Yes :-)

Using trunk build 2002062109 and WinXP.

Thanks a lot for this speedy patch ;-)

Comment 9

16 years ago
verified with windows and mac osx respins
Status: RESOLVED → VERIFIED
*** Bug 153636 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 11

16 years ago
*** Bug 153340 has been marked as a duplicate of this bug. ***

Comment 12

16 years ago
*** Bug 153532 has been marked as a duplicate of this bug. ***

Comment 13

16 years ago
This bug is back !   Installed 2002071718 on Windows NT 4 
yesterday and just noticed this bug a few minutes ago.

The previous build I had used was 20020708xx and the bug
had been fixed in that build.

The "Subject" is being filled in when replying to a newsgroup,
but the recipient is not and the previous message is not being
quoted.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 14

16 years ago
Please do not reopen a bug which has been closed and verified, Instead open a
new one. BTW, the problem you are seeing is bug 157811 which has been already
fixed. Try today's build...
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED
(Assignee)

Comment 15

16 years ago
closed as fixed and verified
Status: RESOLVED → VERIFIED

Comment 16

16 years ago
*** Bug 153339 has been marked as a duplicate of this bug. ***
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.