Starting with Beta 67, let's make aarch64 beta builds available on Mozilla archives

RESOLVED FIXED

Status

enhancement
RESOLVED FIXED
3 months ago
a month ago

People

(Reporter: ritu, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(firefox67 fixed, firefox68 fixed)

Details

Attachments

(7 attachments)

Reporter

Description

3 months ago

Starting with Beta 67, let's make aarch64 beta builds available on Mozilla archives.

Based on my chat with TomPrince, desktop vanilla beta builds will be made available starting the week of March 19th. For DevEd builds, we may need some more time.

Please let me know if you want a separate bug to track DevEd builds.

Reporter

Comment 1

3 months ago

Hi Tom, Chuck, Marnie, FYI.

Flags: needinfo?(mpasciutowood)
Flags: needinfo?(mozilla)
Flags: needinfo?(charmston)

One bug is fine to track both.

TODO:

  • update-verify (after first build)
  • bouncer-check
Flags: needinfo?(mozilla)
Flags: needinfo?(mpasciutowood)
Flags: needinfo?(charmston)

Comment 6

2 months ago
Pushed by mozilla@hocat.ca:
https://hg.mozilla.org/integration/autoland/rev/0a0d380004c7
[win64-aarch64] Enable publishing of win64-aarch64 beta builds; r=mtabara
https://hg.mozilla.org/integration/autoland/rev/2f3183ab11e7
[win64-aarch64] Release win64-aarch64 devedition builds; r=mtabara
Keywords: leave-open

When adding a new platform, the first release will be at the watershed, and
there will be no update paths. Rather than failing in this case (requiring the
update-verify setup happen after the first release), generate an empty config
which will allow the later tasks to turn green.

There was special case logic to map the win64 platform to win32, for stub
entries. When win64-aarch64 was added no special case was added for that
plaform, so they stub entries pointed at the incorrect place. This changes the
configuration so that all stub entries point at the win32 paths, without
needing special case code.

Comment 12

2 months ago
Pushed by mozilla@hocat.ca:
https://hg.mozilla.org/integration/autoland/rev/0ff766eb6349
Support generating update-verify-config for new configuration; r=aki
https://hg.mozilla.org/integration/autoland/rev/0c4e9114a199
Add win64-aarch64 update verify configuration; r=aki
https://hg.mozilla.org/integration/autoland/rev/e847d4ed0e22
[win64-aarch64] Add win64 aarch64 bouner-check configuration; r=mtabara
https://hg.mozilla.org/integration/autoland/rev/f9d9fb959d89
[win64-aarch64] Point win64-aarch64 stub bounce entries at the correct path; r=mtabara
Keywords: leave-open

We always pass in the platform formated as an update platform. Since the only
variation in formats is between major platforms, be liberal in parsing
platforms, when selecting which unpack logic to use. This makes win64-aarch64
support fall out automatically.

Comment hidden (Intermittent Failures Robot)

Comment 17

2 months ago
Pushed by sfraser@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b4258c7fb49b
[win64-aarch64] Simplify logic about unpacking builds in update-verify; r=sfraser

Comment 18

2 months ago
Backout by ncsoregi@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2779f688f9ca
Backed out changeset b4258c7fb49b as per request. CLOSED TREE

Comment 19

2 months ago
Pushed by mozilla@hocat.ca:
https://hg.mozilla.org/integration/autoland/rev/b803066dee9e
[win64-aarch64] Simplify logic about unpacking builds in update-verify; r=sfraser
Comment hidden (Intermittent Failures Robot)
Regressions: 1541807
You need to log in before you can comment on or make changes to this bug.