Closed Bug 153379 Opened 18 years ago Closed 10 years ago

about:mozilla opens new window instead of new tab

Categories

(SeaMonkey :: UI Design, defect)

x86
All
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: Bugzilla-alanjstrBugs, Assigned: jag+mozilla)

References

Details

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1a) Gecko/20020618

When clicking Help->About Mozilla a new window opens to provide the above
information.  When clicking Help->About Plugins, the current tab is replaced.  

I think both should open a new window or a new tab, depending on the user's tab
preference.  I can add a new bug about About Plugins clobbering if you'd like.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Also not a Help bug.
-->blake?
Assignee: oeschger → blaker
Component: Help → XP Apps: GUI Features
QA Contact: tpreston → paw
About Mozilla in OS/2 trunk 2002091808 opens new window as well. This is 4xp, as
Netscape 4.8 is smart enough to reuse the existing window.
Keywords: 4xp
OS: Windows 2000 → All
This would be a bad idea. If bg tab loading is set, user might not notice where
the about information went. We should be using active window, not deciding where
to make a new one. Please WONTFIX.
Summary: About Mozilla opens new window instead of new tab → about:mozilla opens new window instead of new tab
Then override background loading for this situation.  Or use something small
like Firebird does.  

But I use Firebird now, so we can always just close this as "I don't care any
more" ... errr, WONTFIX.  
Product: Core → Mozilla Application Suite
*** Bug 305317 has been marked as a duplicate of this bug. ***
Blake doesn't care about this -> default owner
Assignee: firefox → guifeatures
QA Contact: pawyskoczka
The status of tabbed browsing has changed since this bug was originally filed.

If I've set "A new tab in the current window" as my browser preference for all
links, the menu item should not be disregarding it.  This is only natural, given
that we now have external links open in a new tab if that tabbed browsing
preference is set.  As far as I can tell, this is one of the few (if only)
examples where the preference is now being ignored.

compare bug 250624
Um, is it possible to see any action on this bug? The fix should be trivial,
methinks, but the mages here are endowed with greater wisdom...

Adding self to CC and *voting*.
I don't understand why most people would want to "lose their place", i.e. the current tab, by opening about in a new tab (which - irrelevant perhaps - in most cases will be a window that will be quickly closed).

I certainly don't want this behavior changed, unless a mechanism is provided to allow about:xxx to open in a new window or the current tab - WITHOUT affecting  other normal behavior, i.e. per preferences.
(In reply to comment #8)
> compare bug 250624
> 

Also compare to Firefox Bugzilla Bug 262575
*** Bug 331819 has been marked as a duplicate of this bug. ***
Filter "spam" on "guifeatures-nobody-20080610".
Assignee: guifeatures → nobody
QA Contact: guifeatures
Component: XP Apps: GUI Features → UI Design
Assignee: nobody → jag
QA Contact: guifeatures
Subject is contrary to description. SM2 opens new windows for About Seamonkey and About Plugins each. WFM
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
That last comment is incorrect.  It depends on how you've configured SeaMonkey. (In my case, I always have new tabs open, not windows.)  However, since this bug was first reported, both about:seamonkey and about:plugins do now, in fact, both open up in a new tab (or a new window) without replacing current tab (or window) contents.

So the resolution here actually is correct. :)
You need to log in before you can comment on or make changes to this bug.