Closed Bug 1533794 Opened 6 months ago Closed 6 months ago

browser/components/shell/test/browser_420786.js when Gecko 67 merges to beta on 2019-03-11

Categories

(Firefox :: Shell Integration, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 67
Tracking Status
firefox65 --- unaffected
firefox66 --- unaffected
firefox67 --- verified

People

(Reporter: NarcisB, Assigned: Kwan)

References

Details

Attachments

(1 file)

[Tracking Requested - why for this release]:

Central as Beta simulation:
https://treeherder.mozilla.org/#/jobs?repo=try&resultStatus=testfailed%2Cbusted%2Cexception%2Crunnable&classifiedState=unclassified&revision=593aa37ef063396bb253d23b17c3be9bc463bc28&selectedJob=232693739

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=232693739&repo=try&lineNumber=4412

Log snippet:

[task 2019-03-08T15:56:00.908Z] 15:56:00 INFO - TEST-START | browser/components/shell/test/browser_420786.js
[task 2019-03-08T15:56:01.364Z] 15:56:01 INFO - TEST-INFO | started process screentopng
[task 2019-03-08T15:56:02.274Z] 15:56:02 INFO - TEST-INFO | screentopng: exit 0
[task 2019-03-08T15:56:02.276Z] 15:56:02 INFO - Buffered messages logged at 15:56:00
[task 2019-03-08T15:56:02.277Z] 15:56:02 INFO - Entering test bound
[task 2019-03-08T15:56:02.277Z] 15:56:02 INFO - Buffered messages logged at 15:56:01
[task 2019-03-08T15:56:02.278Z] 15:56:02 INFO - TEST-PASS | browser/components/shell/test/browser_420786.js | image can be accessed synchronously from the parent process - true == true -
[task 2019-03-08T15:56:02.279Z] 15:56:02 INFO - TEST-PASS | browser/components/shell/test/browser_420786.js | Wallpaper was written to disk -
[task 2019-03-08T15:56:02.280Z] 15:56:02 INFO - Buffered messages finished
[task 2019-03-08T15:56:02.281Z] 15:56:02 INFO - TEST-UNEXPECTED-FAIL | browser/components/shell/test/browser_420786.js | Wallpaper file GSettings key is correct - Got file:///builds/worker/Firefox%20Developer%20Edition_wallpaper.png, expected file:///builds/worker/Firefox Developer Edition_wallpaper.png
[task 2019-03-08T15:56:02.282Z] 15:56:02 INFO - Stack trace:
[task 2019-03-08T15:56:02.283Z] 15:56:02 INFO - chrome://mochikit/content/browser-test.js:test_is:1315
[task 2019-03-08T15:56:02.284Z] 15:56:02 INFO - chrome://mochitests/content/browser/browser/components/shell/test/browser_420786.js:checkWallpaper:62
[task 2019-03-08T15:56:02.285Z] 15:56:02 INFO - chrome://mochitests/content/browser/browser/components/shell/test/browser_420786.js:null:99
[task 2019-03-08T15:56:02.285Z] 15:56:02 INFO - resource://testing-common/BrowserTestUtils.jsm:withNewTab:111
[task 2019-03-08T15:56:02.285Z] 15:56:02 INFO - TEST-PASS | browser/components/shell/test/browser_420786.js | Wallpaper position GSettings key is correct -
[task 2019-03-08T15:56:02.286Z] 15:56:02 INFO - TEST-PASS | browser/components/shell/test/browser_420786.js | Wallpaper was written to disk -
[task 2019-03-08T15:56:02.286Z] 15:56:02 INFO - Not taking screenshot here: see the one that was previously logged

Fail was caused by https://bugzilla.mozilla.org/show_bug.cgi?id=1529363
:kwan , could you please take a look?

Flags: needinfo?(moz-ian)
Assignee: nobody → moz-ian
Status: NEW → ASSIGNED
Flags: needinfo?(moz-ian)
Keywords: checkin-needed

Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/7e6212df6075
encodeURI() expected path to account for possible spaces in filename. r=MattN

Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
You need to log in before you can comment on or make changes to this bug.