Closed Bug 1533807 Opened 9 months ago Closed 4 months ago

Intermittent browser/components/urlbar/tests/browser/browser_raceWithTabs.js | Test timed out -

Categories

(Firefox :: Address Bar, defect, P5)

defect

Tracking

()

RESOLVED WORKSFORME
Firefox 70

People

(Reporter: intermittent-bug-filer, Unassigned)

References

Details

(Keywords: intermittent-failure, regression, Whiteboard: [retriggered][stockwell disabled])

Attachments

(1 file)

#[markdown(off)]
Filed by: nbeleuzu [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=232703889&repo=autoland

https://queue.taskcluster.net/v1/task/USzaMIS7Qj-ih-FkYhuuCQ/runs/0/artifacts/public/logs/live_backing.log

[task 2019-03-08T16:58:16.604Z] 16:58:16 INFO - TEST-START | browser/components/urlbar/tests/browser/browser_raceWithTabs.js
[task 2019-03-08T16:59:01.638Z] 16:59:01 INFO - TEST-INFO | started process screentopng
[task 2019-03-08T16:59:02.186Z] 16:59:02 INFO - TEST-INFO | screentopng: exit 0
[task 2019-03-08T16:59:02.188Z] 16:59:02 INFO - Buffered messages logged at 16:58:16
[task 2019-03-08T16:59:02.189Z] 16:59:02 INFO - Entering test bound hitEnterLoadInRightTab
[task 2019-03-08T16:59:02.190Z] 16:59:02 INFO - Creating bookmark and keyword
[task 2019-03-08T16:59:02.191Z] 16:59:02 INFO - Opening a tab
[task 2019-03-08T16:59:02.192Z] 16:59:02 INFO - Filling URL bar, sending <return> and opening a tab
[task 2019-03-08T16:59:02.192Z] 16:59:02 INFO - Immediately open a second tab
[task 2019-03-08T16:59:02.192Z] 16:59:02 INFO - Created new tab; waiting for tabs to load
[task 2019-03-08T16:59:02.193Z] 16:59:02 INFO - Buffered messages logged at 16:58:17
[task 2019-03-08T16:59:02.195Z] 16:59:02 INFO - New tab loaded
[task 2019-03-08T16:59:02.197Z] 16:59:02 INFO - Console message: [JavaScript Error: "getScreenshot(https://example.com/browser/browser/components/urlbar/tests/browser/dummy_page.html) failed: TypeError: NetworkError when attempting to fetch resource." {file: "resource://activity-stream/lib/Screenshots.jsm" line: 45}]
[task 2019-03-08T16:59:02.198Z] 16:59:02 INFO - getScreenshotForURL@resource://activity-stream/lib/Screenshots.jsm:45:10
[task 2019-03-08T16:59:02.199Z] 16:59:02 INFO - async*maybeCacheScreenshot@resource://activity-stream/lib/Screenshots.jsm:98:37
[task 2019-03-08T16:59:02.200Z] 16:59:02 INFO - fetchImage@resource://activity-stream/lib/HighlightsFeed.jsm:226:17
[task 2019-03-08T16:59:02.201Z] 16:59:02 INFO - fetchHighlights@resource://activity-stream/lib/HighlightsFeed.jsm:181:14
[task 2019-03-08T16:59:02.205Z] 16:59:02 INFO - async*onAction@resource://activity-stream/lib/HighlightsFeed.jsm:291:14
[task 2019-03-08T16:59:02.206Z] 16:59:02 INFO - _middleware/</<@resource://activity-stream/lib/Store.jsm:51:17
[task 2019-03-08T16:59:02.207Z] 16:59:02 INFO - Store/this[method]@resource://activity-stream/lib/Store.jsm:29:54
[task 2019-03-08T16:59:02.209Z] 16:59:02 INFO - customDispatch/this.placesChangedTimer<@resource://activity-stream/lib/PlacesFeed.jsm:202:22
[task 2019-03-08T16:59:02.210Z] 16:59:02 INFO -
[task 2019-03-08T16:59:02.212Z] 16:59:02 INFO - Buffered messages finished
[task 2019-03-08T16:59:02.215Z] 16:59:02 INFO - TEST-UNEXPECTED-FAIL | browser/components/urlbar/tests/browser/browser_raceWithTabs.js | Test timed out -
[task 2019-03-08T16:59:02.215Z] 16:59:02 INFO - GECKO(7873) | MEMORY STAT | vsize 1974MB | residentFast 335MB | heapAllocated 114MB
[task 2019-03-08T16:59:02.216Z] 16:59:02 INFO - TEST-OK | browser/components/urlbar/tests/browser/browser_raceWithTabs.js | took 45082ms
[task 2019-03-08T16:59:02.217Z] 16:59:02 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-03-08T16:59:02.219Z] 16:59:02 INFO - TEST-UNEXPECTED-FAIL | browser/components/urlbar/tests/browser/browser_raceWithTabs.js | Found a tab after previous test timed out: about:newtab -
[task 2019-03-08T16:59:02.220Z] 16:59:02 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-03-08T16:59:02.221Z] 16:59:02 INFO - TEST-UNEXPECTED-FAIL | browser/components/urlbar/tests/browser/browser_raceWithTabs.js | Found a tab after previous test timed out: about:newtab -

See Also: → 1382456

In the log I see "New tab loaded", so about:newtab has been loaded properly, but I don't see the load message for the old tab, that sounds like it is never loaded.
I wonder if there's a race for which the deferred Enter event gets discarded due to a blur caused by about:newtab.

And again, it's mostly linux :(

Whiteboard: [retriggered]
Priority: P5 → P2

let's disable this again on linux, as it was.

Assignee: nobody → mak77
Status: NEW → ASSIGNED
Keywords: leave-open
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/7f359721143c
Skip browser_raceWithTabs.js on Linux. r=Standard8
Priority: P2 → P5

No other occurrences since this landed.

Whiteboard: [retriggered][stockwell disable-recommended] → [retriggered][stockwell disabled]
Assignee: mak77 → nobody
Status: ASSIGNED → NEW

This was already failing intermittently on linux before QB, it continues doing so, thus it's likely unrelated.

No longer blocks: quantumbar-tests
Depends on: 1566776

didn't fail recently in Nightly, after bug 1566776 re-enabled it.

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → WORKSFORME
Target Milestone: --- → Firefox 70
You need to log in before you can comment on or make changes to this bug.