Closed Bug 1533922 Opened 3 years ago Closed 3 years ago

macOS - Fix mozmill to run tests

Categories

(Thunderbird :: Testing Infrastructure, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 68.0

People

(Reporter: aleca, Assigned: Fallen)

Details

Attachments

(2 files, 1 obsolete file)

Attached patch mozmill-test.patch (obsolete) — Splinter Review

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:65.0) Gecko/20100101 Firefox/65.0

Steps to reproduce:

Philipp Kewisch <mozilla@kewis.ch> took care of fixing this bug that was preventing developers on macos to run mozmill-one tests.

Attachment #9049672 - Attachment is patch: true
Attachment #9049672 - Attachment mime type: text/x-patch → text/plain
Assignee: nobody → philipp
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Comment on attachment 9049672 [details] [diff] [review]
mozmill-test.patch

I'm afraid the patch break MozMill on Windows, now I get what Mac users have been seeing before:
```
mozrunner.errors.RunnerNotStartedError: Failed to start the process: [Error 2] The system cannot find the file specified.
```

:-(

Aceman, how about on Linux?
Attachment #9049672 - Flags: feedback-
Attachment #9049672 - Flags: feedback?(acelists)

Philipp also offered an initial version on IRC last night:

23:52:31 - Fallen: fix: https://www.irccloud.com/pastebin/NAKFqfYR/
23:52:52 - Fallen: oh there is already ABS_DIST, might as well use that
23:54:13 - Fallen: better fix: https://www.irccloud.com/pastebin/1bLDHJF7/

I've attached it here and it does NOT break Windows, so maybe we go with this since the "better" fix isn't really better ;-)

Attachment #9049726 - Flags: feedback+
Comment on attachment 9049726 [details] [diff] [review]
mozmill-test.patch (v0)

Aceman, please try on Linux, Arshad on Mac and Philipp, please let us know whether you'd be happy to land the initial solution.
Attachment #9049726 - Flags: feedback?(philipp)
Attachment #9049726 - Flags: feedback?(arshdkhn1)
Attachment #9049726 - Flags: feedback?(acelists)
Comment on attachment 9049672 [details] [diff] [review]
mozmill-test.patch

Review of attachment 9049672 [details] [diff] [review]:
-----------------------------------------------------------------

Yes, this one breaks mozmill on Linux.
Attachment #9049672 - Flags: feedback?(acelists) → feedback-
Comment on attachment 9049726 [details] [diff] [review]
mozmill-test.patch (v0)

Review of attachment 9049726 [details] [diff] [review]:
-----------------------------------------------------------------

This one works on Linux.
Attachment #9049726 - Flags: feedback?(acelists) → feedback+
Comment on attachment 9049726 [details] [diff] [review]
mozmill-test.patch (v0)

Review of attachment 9049726 [details] [diff] [review]:
-----------------------------------------------------------------

Solo test commands works now.
Attachment #9049726 - Flags: feedback?(arshdkhn1) → feedback+

The second one is better from a code quality POV because we are re-using variables, so maybe it makes sense to just figure out why it breaks windows. I'll need some more lines of logs from Windows to see what exactly it passes to --binary. On mac there was an array with the exact command being executed.

The issue for mac was that the APP_NAME contains spaces, so calling $(abspath) on it fails. Note $(abspath path/to/foo bar/baz) produces /abs/path/to/foo /abs/bar/baz.

Is that what you need? We can get Aceman to do you a log on Linux.

Flags: needinfo?(philipp)

Hm interesting, so ABS_DIST is not actually absolute!? This should be fixed somewhere upstream then. Lots of hassle for such a small change so I guess go with whatever works and future self will have to deal with it.

Flags: needinfo?(philipp)
Attachment #9049726 - Flags: feedback?(philipp) → feedback+
Attachment #9049672 - Attachment is obsolete: true

OK, I'll get the agreed patch landed attributing it to Philipp, of course.

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/2e64da7cd108
fix 'make mozmill-one SOLO_TEST=' on Mac. f=aceman,arshad rs=jorgk

Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 68.0
You need to log in before you can comment on or make changes to this bug.