problem with double dash/minus inside HTML comment

VERIFIED INVALID

Status

()

Core
HTML: Parser
VERIFIED INVALID
16 years ago
15 years ago

People

(Reporter: Laurent Bonnaud, Assigned: harishd)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020610
Debian/1.2.5-1
BuildID:    20020610

A HTML comment (<-- ...  -->) containing a double dash/minus 
(--) causes the rest of the document to be interpreted 
as a comment.


Reproducible: Always
Steps to Reproduce:
Load http://irancy.lis.inpg.fr/~bonnaud/foo.html
in the browser.

Actual Results:  "text1 text3"
is displayed.

In the HTML source view, "text2" is colorized as a comment.


Expected Results:  "text1 text2 text3"
should be displayed.


If I remove the XHTML DocType, the bug goes away.
See <URL:http://www.w3.org/TR/html401/intro/sgmltut.html#h-3.2.4>. This is 
correct.

INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
Verified. The doctype triggers our "standards" mode in which we actually
implement correct comment parsing...
Status: RESOLVED → VERIFIED

Comment 3

15 years ago
*** Bug 212842 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.